symfony/process (Packagist)
Advisories
8
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 8.0.5 or later clears every advisory below that has a fix.
Upgrade commands
composer
composer require symfony/process:^8.0.5Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-r39x-jcww-82v6 Symfony's incorrect argument escaping under MSYS2/Git Bash can lead to destructive file operations on Windows |
Medium EPSS 0.23% |
< 5.4.51 | 5.4.51 |
| GHSA-r39x-jcww-82v6 Symfony's incorrect argument escaping under MSYS2/Git Bash can lead to destructive file operations on Windows |
Medium EPSS 0.23% |
>= 6.4, < 6.4.33 | 6.4.33 |
| GHSA-r39x-jcww-82v6 Symfony's incorrect argument escaping under MSYS2/Git Bash can lead to destructive file operations on Windows |
Medium EPSS 0.23% |
>= 7.3, < 7.3.11 | 7.3.11 |
| GHSA-r39x-jcww-82v6 Symfony's incorrect argument escaping under MSYS2/Git Bash can lead to destructive file operations on Windows |
Medium EPSS 0.23% |
>= 7.4, < 7.4.5 | 7.4.5 |
| GHSA-r39x-jcww-82v6 Symfony's incorrect argument escaping under MSYS2/Git Bash can lead to destructive file operations on Windows |
Medium EPSS 0.23% |
>= 8.0, < 8.0.5 | 8.0.5 |
| GHSA-qq5c-677p-737q Symfony vulnerable to command execution hijack on Windows with Process class |
Critical EPSS 0.43% |
< 5.4.46 | 5.4.46 |
| GHSA-qq5c-677p-737q Symfony vulnerable to command execution hijack on Windows with Process class |
Critical EPSS 0.43% |
>= 6.0.0, < 6.4.14 | 6.4.14 |
| GHSA-qq5c-677p-737q Symfony vulnerable to command execution hijack on Windows with Process class |
Critical EPSS 0.43% |
>= 7.0.0, < 7.1.7 | 7.1.7 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor