Skip to content

symfony/phpunit-bridge (Packagist)

Advisories
4
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 4.2.7 or later clears every advisory below that has a fix.

Upgrade commands
composer
composer require symfony/phpunit-bridge:^4.2.7

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-w2fr-65vp-mxw3
Deserialization of untrusted data in Symfony
High
EPSS 2.26%
>= 2.8.0, < 2.8.50
2.8.50
GHSA-w2fr-65vp-mxw3
Deserialization of untrusted data in Symfony
High
EPSS 2.26%
>= 3.0.0, < 3.4.26
3.4.26
GHSA-w2fr-65vp-mxw3
Deserialization of untrusted data in Symfony
High
EPSS 2.26%
>= 4.0.0, < 4.1.12
4.1.12
GHSA-w2fr-65vp-mxw3
Deserialization of untrusted data in Symfony
High
EPSS 2.26%
>= 4.2.0, < 4.2.7
4.2.7
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor