symfony/framework-bundle (Packagist)
Advisories
8
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 4.2.7 or later clears every advisory below that has a fix.
Upgrade commands
composer
composer require symfony/framework-bundle:^4.2.7Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-wfv7-5x33-v22h Code injection in the way Symfony implements translation caching in FrameworkBundle |
High | >= 2.0.0, < 2.3.18 | 2.3.18 |
| GHSA-wfv7-5x33-v22h Code injection in the way Symfony implements translation caching in FrameworkBundle |
High | >= 2.4.0, < 2.4.8 | 2.4.8 |
| GHSA-wfv7-5x33-v22h Code injection in the way Symfony implements translation caching in FrameworkBundle |
High | >= 2.5.0, < 2.5.2 | 2.5.2 |
| GHSA-g996-q5r8-w7g2 Symfony Cross-site Scripting (XSS) vulnerability |
Medium EPSS 1.03% |
>= 4.0.0, < 4.1.12 | 4.1.12 |
| GHSA-g996-q5r8-w7g2 Symfony Cross-site Scripting (XSS) vulnerability |
Medium EPSS 1.03% |
>= 2.7.0, < 2.7.51 | 2.7.51 |
| GHSA-g996-q5r8-w7g2 Symfony Cross-site Scripting (XSS) vulnerability |
Medium EPSS 1.03% |
>= 4.2.0, < 4.2.7 | 4.2.7 |
| GHSA-g996-q5r8-w7g2 Symfony Cross-site Scripting (XSS) vulnerability |
Medium EPSS 1.03% |
>= 2.8.0, < 2.8.50 | 2.8.50 |
| GHSA-g996-q5r8-w7g2 Symfony Cross-site Scripting (XSS) vulnerability |
Medium EPSS 1.03% |
>= 3.0.0, < 3.4.26 | 3.4.26 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor