symfony/cache (Packagist)
Advisories
10
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 8.0.12 or later clears every advisory below that has a fix.
Upgrade commands
composer
composer require symfony/cache:^8.0.12Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-6qh9-h6wf-jgqc Symfony Vulnerable to SQL Injection in PdoAdapter::doClear() via Unsanitized $prefix |
High EPSS 0.46% |
>= 7.0.0, < 7.4.12 | 7.4.12 |
| GHSA-6qh9-h6wf-jgqc Symfony Vulnerable to SQL Injection in PdoAdapter::doClear() via Unsanitized $prefix |
High EPSS 0.46% |
>= 6.0.0, < 6.4.40 | 6.4.40 |
| GHSA-6qh9-h6wf-jgqc Symfony Vulnerable to SQL Injection in PdoAdapter::doClear() via Unsanitized $prefix |
High EPSS 0.46% |
< 5.4.52 | 5.4.52 |
| GHSA-6qh9-h6wf-jgqc Symfony Vulnerable to SQL Injection in PdoAdapter::doClear() via Unsanitized $prefix |
High EPSS 0.46% |
>= 8.0.0, < 8.0.12 | 8.0.12 |
| GHSA-w2fr-65vp-mxw3 Deserialization of untrusted data in Symfony |
High EPSS 2.26% |
>= 3.1.0, < 3.4.26 | 3.4.26 |
| GHSA-w2fr-65vp-mxw3 Deserialization of untrusted data in Symfony |
High EPSS 2.26% |
>= 4.0.0, < 4.1.12 | 4.1.12 |
| GHSA-w2fr-65vp-mxw3 Deserialization of untrusted data in Symfony |
High EPSS 2.26% |
>= 4.2.0, < 4.2.7 | 4.2.7 |
| GHSA-79gr-58r3-pwm3 Symfony Unsafe Cache Serialization Could Enable RCE |
Critical EPSS 33.25% |
>= 4.3.0, < 4.3.8 | 4.3.8 |
| GHSA-79gr-58r3-pwm3 Symfony Unsafe Cache Serialization Could Enable RCE |
Critical EPSS 33.25% |
>= 4.0.0, < 4.2.12 | 4.2.12 |
| GHSA-79gr-58r3-pwm3 Symfony Unsafe Cache Serialization Could Enable RCE |
Critical EPSS 33.25% |
>= 3.1.0, < 3.4.35 | 3.4.35 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor