Skip to content

mautic/core-lib (Packagist)

Advisories
10
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 5.1.1 or later clears every advisory below that has a fix.

Upgrade commands
composer
composer require mautic/core-lib:^5.1.1

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-qf6m-6m4g-rmrc
Mautic has insufficient authentication in upgrade flow
High
EPSS 0.28%
>= 1.0.0-beta3, < 4.4.13
4.4.13
GHSA-qf6m-6m4g-rmrc
Mautic has insufficient authentication in upgrade flow
High
EPSS 0.28%
>= 5.0.0-alpha, < 5.1.1
5.1.1
GHSA-xpc5-rr39-v8v2
Mautic has an XSS in contact tracking and page hits report
Medium
EPSS 0.29%
>= 1.0.0-beta4, < 4.4.13
4.4.13
GHSA-xpc5-rr39-v8v2
Mautic has an XSS in contact tracking and page hits report
Medium
EPSS 0.29%
>= 5.0.0-alpha, < 5.1.1
5.1.1
GHSA-xv68-rrmw-9xwf
Mautic vulnerable to Cross-site Scripting (XSS) - stored (edit form HTML field)
Medium
EPSS 0.21%
>= 1.0.0-beta, < 4.4.13
4.4.13
GHSA-xv68-rrmw-9xwf
Mautic vulnerable to Cross-site Scripting (XSS) - stored (edit form HTML field)
Medium
EPSS 0.21%
>= 5.0.0-alpha, < 5.1.1
5.1.1
GHSA-73gr-32wg-qhh7
Mautic vulnerable to XSS in contact/company tracking (no authentication)
Medium
EPSS 0.31%
>= 2.6.0, < 4.4.13
4.4.13
GHSA-73gr-32wg-qhh7
Mautic vulnerable to XSS in contact/company tracking (no authentication)
Medium
EPSS 0.31%
>= 5.0.0-alpha, < 5.1.1
5.1.1
GHSA-x3jx-5w6m-q2fc
Mautic vulnerable to Improper Access Control in UI upgrade process
Medium
EPSS 0.29%
>= 5.0.0-alpha, < 5.1.1
5.1.1
GHSA-x3jx-5w6m-q2fc
Mautic vulnerable to Improper Access Control in UI upgrade process
Medium
EPSS 0.29%
>= 1.1.3, < 4.4.13
4.4.13
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor