illuminate/database (Packagist)
Advisories
8
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 8.40.0 or later clears every advisory below that has a fix.
Upgrade commands
composer
composer require illuminate/database:^8.40.0Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-4mg9-vhxq-vm7j SQL Server LIMIT / OFFSET SQL Injection in laravel/framework and illuminate/database |
High | >= 8.0.0, < 8.40.0 | 8.40.0 |
| GHSA-4mg9-vhxq-vm7j SQL Server LIMIT / OFFSET SQL Injection in laravel/framework and illuminate/database |
High | < 6.20.26 | 6.20.26 |
| GHSA-x7p5-p2c9-phvg Unexpected database bindings |
High | >= 8.0.0, < 8.24.0 | 8.24.0 |
| GHSA-x7p5-p2c9-phvg Unexpected database bindings |
High | < 6.20.14 | 6.20.14 |
| GHSA-x7p5-p2c9-phvg Unexpected database bindings |
High | >= 7.0.0, < 7.30.4 | 7.30.4 |
| GHSA-3p32-j457-pg5x Query Binding Exploitation |
High EPSS 1.62% |
>= 7.0.0, < 7.30.3 | 7.30.3 |
| GHSA-3p32-j457-pg5x Query Binding Exploitation |
High EPSS 1.62% |
>= 6.0.0, < 6.20.12 | 6.20.12 |
| GHSA-3p32-j457-pg5x Query Binding Exploitation |
High EPSS 1.62% |
>= 8.0.0, < 8.22.1 | 8.22.1 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor