guzzlehttp/psr7 (Packagist)
Advisories
4
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 2.4.5 or later clears every advisory below that has a fix.
Upgrade commands
composer
composer require guzzlehttp/psr7:^2.4.5Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-wxmh-65f7-jcvw Improper header name validation in guzzlehttp/psr7 |
High EPSS 1.22% |
>= 2.0.0, < 2.4.5 | 2.4.5 |
| GHSA-wxmh-65f7-jcvw Improper header name validation in guzzlehttp/psr7 |
High EPSS 1.22% |
< 1.9.1 | 1.9.1 |
| DRUPAL-CORE-2022-006 Improper Input Validation in guzzlehttp/psr7 |
Medium EPSS 2.48% |
< 1.8.4 | 1.8.4 |
| DRUPAL-CORE-2022-006 Improper Input Validation in guzzlehttp/psr7 |
Medium EPSS 2.48% |
>= 2.0.0, < 2.1.1 | 2.1.1 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor