guzzlehttp/guzzle (Packagist)
Advisories
9
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 7.4.4 or later clears every advisory below that has a fix.
Upgrade commands
composer
composer require guzzlehttp/guzzle:^7.4.4Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| DRUPAL-CORE-2022-011 Failure to strip the Cookie header on change in host or HTTP downgrade |
High EPSS 1.99% |
>= 4.0.0, < 6.5.7 | 6.5.7 |
| DRUPAL-CORE-2022-011 Failure to strip the Cookie header on change in host or HTTP downgrade |
High EPSS 1.99% |
>= 7.0.0, < 7.4.4 | 7.4.4 |
| DRUPAL-CORE-2022-011 Failure to strip the Cookie header on change in host or HTTP downgrade |
High EPSS 1.99% |
>= 4.0.0, < 6.5.7 | 6.5.7 |
| DRUPAL-CORE-2022-011 Failure to strip the Cookie header on change in host or HTTP downgrade |
High EPSS 1.99% |
>= 7.0.0, < 7.4.4 | 7.4.4 |
| DRUPAL-CORE-2022-010 Cross-domain cookie leakage in Guzzle |
High EPSS 1.36% |
< 6.5.6 | 6.5.6 |
| DRUPAL-CORE-2022-010 Cross-domain cookie leakage in Guzzle |
High EPSS 1.36% |
>= 7.0.0, < 7.4.3 | 7.4.3 |
| GHSA-m6ch-gg5f-wxx3 HTTP Proxy header vulnerability |
High EPSS 50.43% |
>= 6, < 6.2.1 | 6.2.1 |
| GHSA-m6ch-gg5f-wxx3 HTTP Proxy header vulnerability |
High EPSS 50.43% |
>= 4.0.0-rc2, < 4.2.4 | 4.2.4 |
| GHSA-m6ch-gg5f-wxx3 HTTP Proxy header vulnerability |
High EPSS 50.43% |
>= 5, < 5.3.1 | 5.3.1 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor