google/protobuf (Packagist)
Advisories
4
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 3.15.0 or later clears every advisory below that has a fix.
Upgrade commands
composer
composer require google/protobuf:^3.15.0Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| PYSEC-2022-48 Withdrawn Advisory: NULL Pointer Dereference in Protocol Buffers |
High EPSS 2.66% |
< 3.15.0 | 3.15.0 |
| PYSEC-2022-48 Withdrawn Advisory: NULL Pointer Dereference in Protocol Buffers |
High EPSS 2.66% |
< 3.15.0 | 3.15.0 |
| GHSA-jwvw-v7c5-m82h protobuf susceptible to buffer overflow |
High EPSS 4.96% |
< 3.4.0 | 3.4.0 |
| GHSA-jwvw-v7c5-m82h protobuf susceptible to buffer overflow |
High EPSS 4.96% |
< 3.4.0 | 3.4.0 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor