Skip to content

drupal/core-recommended (Packagist)

Advisories
18
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 11.0.8 or later clears every advisory below that has a fix.

Upgrade commands
composer
composer require drupal/core-recommended:^11.0.8

Known vulnerabilities

AdvisorySeverityAffectedFixed in
DRUPAL-CORE-2024-008
Drupal core contains a potential PHP Object Injection vulnerability
Critical
EPSS 0.98%
>= 8.8.0, < 10.2.11
10.2.11
DRUPAL-CORE-2024-008
Drupal core contains a potential PHP Object Injection vulnerability
Critical
EPSS 0.98%
>= 7.0, < 7.102
7.102
DRUPAL-CORE-2024-008
Drupal core contains a potential PHP Object Injection vulnerability
Critical
EPSS 0.98%
>= 10.3.0, < 10.3.9
10.3.9
DRUPAL-CORE-2024-007
Drupal core contains a potential PHP Object Injection vulnerability
Critical
EPSS 0.83%
>= 8.8.0, < 10.2.11
10.2.11
DRUPAL-CORE-2024-007
Drupal core contains a potential PHP Object Injection vulnerability
Critical
EPSS 0.83%
>= 11.0.0, < 11.0.8
11.0.8
DRUPAL-CORE-2024-007
Drupal core contains a potential PHP Object Injection vulnerability
Critical
EPSS 0.83%
>= 10.3.0, < 10.3.9
10.3.9
DRUPAL-CORE-2024-006
Drupal core contains a potential PHP Object Injection vulnerability
Critical
EPSS 0.93%
>= 10.3.0, < 10.3.9
10.3.9
DRUPAL-CORE-2024-006
Drupal core contains a potential PHP Object Injection vulnerability
Critical
EPSS 0.93%
>= 11.0.0, < 11.0.8
11.0.8
DRUPAL-CORE-2024-006
Drupal core contains a potential PHP Object Injection vulnerability
Critical
EPSS 0.93%
>= 8.8.0, < 10.2.11
10.2.11
DRUPAL-CORE-2024-004
Drupal core Access bypass
High
EPSS 0.41%
>= 8.0.0, < 10.2.11
10.2.11
DRUPAL-CORE-2024-004
Drupal core Access bypass
High
EPSS 0.41%
>= 10.3.0, < 10.3.9
10.3.9
DRUPAL-CORE-2024-004
Drupal core Access bypass
High
EPSS 0.41%
>= 11.0.0, < 11.0.8
11.0.8
DRUPAL-CORE-2024-003
Drupal Core Cross-Site Scripting (XSS)
Medium
EPSS 0.34%
>= 11.0.0, < 11.0.8
11.0.8
DRUPAL-CORE-2024-003
Drupal Core Cross-Site Scripting (XSS)
Medium
EPSS 0.34%
>= 10.3.0, < 10.3.9
10.3.9
DRUPAL-CORE-2024-003
Drupal Core Cross-Site Scripting (XSS)
Medium
EPSS 0.34%
>= 8.8.0, < 10.2.11
10.2.11
GHSA-mg8j-w93w-xjgc
Drupal Full Path Disclosure
Medium
EPSS 9.27%
>= 10.3.0, < 10.3.6
10.3.6
GHSA-mg8j-w93w-xjgc
Drupal Full Path Disclosure
Medium
EPSS 9.27%
>= 8.0.0, < 10.2.9
10.2.9
GHSA-mg8j-w93w-xjgc
Drupal Full Path Disclosure
Medium
EPSS 9.27%
>= 11.0.0, < 11.0.5
11.0.5
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor