struts:struts (Maven)
Advisories
3
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 1.2.9 or later clears every advisory below that has a fix.
Upgrade commands
maven
<dependency><groupId>struts</groupId><artifactId>struts</artifactId><version>1.2.9</version></dependency>gradle
implementation("struts:struts:1.2.9")Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-4g42-gqrg-4633 Apache Struts vulnerable to memory exhaustion |
High EPSS 5.51% |
<= 1.2.9 | No fix yet |
| GHSA-7qwv-cwgj-c8rj Improper Input Validation in Apache Struts Known exploited |
High EPSS 54.63% |
< 1.2.9 | 1.2.9 |
| GHSA-7qwv-cwgj-c8rj Improper Input Validation in Apache Struts Known exploited |
High EPSS 54.63% |
< 1.2.9 | 1.2.9 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor