Skip to content

org.zkoss.zk:zk (Maven)

Advisories
10
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 9.6.2 or later clears every advisory below that has a fix.

Upgrade commands
maven
<dependency><groupId>org.zkoss.zk</groupId><artifactId>zk</artifactId><version>9.6.2</version></dependency>
gradle
implementation("org.zkoss.zk:zk:9.6.2")

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-6278-2q4m-cmf3
ZK Framework vulnerable to malicious POST
Known exploited
High
EPSS 95.40%
< 8.6.4.2
8.6.4.2
GHSA-6278-2q4m-cmf3
ZK Framework vulnerable to malicious POST
Known exploited
High
EPSS 95.40%
>= 9.0.0.0, < 9.0.1.3
9.0.1.3
GHSA-6278-2q4m-cmf3
ZK Framework vulnerable to malicious POST
Known exploited
High
EPSS 95.40%
>= 9.5.0.0, < 9.5.1.4
9.5.1.4
GHSA-6278-2q4m-cmf3
ZK Framework vulnerable to malicious POST
Known exploited
High
EPSS 95.40%
>= 9.6.0.0, < 9.6.0.2
9.6.0.2
GHSA-6278-2q4m-cmf3
ZK Framework vulnerable to malicious POST
Known exploited
High
EPSS 95.40%
>= 9.6.1, < 9.6.2
9.6.2
GHSA-6278-2q4m-cmf3
ZK Framework vulnerable to malicious POST
Known exploited
High
EPSS 95.40%
< 8.6.4.2
8.6.4.2
GHSA-6278-2q4m-cmf3
ZK Framework vulnerable to malicious POST
Known exploited
High
EPSS 95.40%
>= 9.0.0.0, < 9.0.1.3
9.0.1.3
GHSA-6278-2q4m-cmf3
ZK Framework vulnerable to malicious POST
Known exploited
High
EPSS 95.40%
>= 9.5.0.0, < 9.5.1.4
9.5.1.4
GHSA-6278-2q4m-cmf3
ZK Framework vulnerable to malicious POST
Known exploited
High
EPSS 95.40%
>= 9.6.0.0, < 9.6.0.2
9.6.0.2
GHSA-6278-2q4m-cmf3
ZK Framework vulnerable to malicious POST
Known exploited
High
EPSS 95.40%
>= 9.6.1, < 9.6.2
9.6.2
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor