Skip to content

org.xwiki.platform:xwiki-platform-legacy-oldcore (Maven)

Advisories
14
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 17.10.1 or later clears every advisory below that has a fix.

Upgrade commands
maven
<dependency><groupId>org.xwiki.platform</groupId><artifactId>xwiki-platform-legacy-oldcore</artifactId><version>17.10.1</version></dependency>
gradle
implementation("org.xwiki.platform:xwiki-platform-legacy-oldcore:17.10.1")

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-mrqg-xmgm-rc5g
XWiki's REST APIs can list all pages/spaces, leading to unavailability
High
EPSS 0.40%
>= 1.8-rc-1, < 16.10.16
16.10.16
GHSA-mrqg-xmgm-rc5g
XWiki's REST APIs can list all pages/spaces, leading to unavailability
High
EPSS 0.40%
>= 17.0.0-rc-1, < 17.4.8
17.4.8
GHSA-mrqg-xmgm-rc5g
XWiki's REST APIs can list all pages/spaces, leading to unavailability
High
EPSS 0.40%
>= 17.5.0-rc-1, < 17.10.1
17.10.1
GHSA-h259-74h5-4rh9
XWiki vulnerable to remote code execution with script right through unprotected Velocity scripting API
Critical
EPSS 0.54%
>= 17.0.0-rc-1, < 17.4.8
17.4.8
GHSA-h259-74h5-4rh9
XWiki vulnerable to remote code execution with script right through unprotected Velocity scripting API
Critical
EPSS 0.54%
>= 17.5.0-rc-1, < 17.10.1
17.10.1
GHSA-57q2-6cp4-9mq3
XWiki exposes passwords and emails stored in fields not named password/email in xml.vm
Medium
EPSS 1.45%
>= 16.5.0-rc-1, < 16.10.5
16.10.5
GHSA-57q2-6cp4-9mq3
XWiki exposes passwords and emails stored in fields not named password/email in xml.vm
Medium
EPSS 1.45%
>= 17.0.0-rc-1, < 17.2.0-rc-1
17.2.0-rc-1
GHSA-57q2-6cp4-9mq3
XWiki exposes passwords and emails stored in fields not named password/email in xml.vm
Medium
EPSS 1.45%
>= 1.1, < 16.4.7
16.4.7
GHSA-r38m-cgpg-qj69
XWiki leaks password hashes and other accessible password properties
Medium
EPSS 0.48%
>= 17.0.0-rc-1, < 17.2.0-rc-1
17.2.0-rc-1
GHSA-r38m-cgpg-qj69
XWiki leaks password hashes and other accessible password properties
Medium
EPSS 0.48%
>= 9.8-rc-1, < 16.4.7
16.4.7
GHSA-r38m-cgpg-qj69
XWiki leaks password hashes and other accessible password properties
Medium
EPSS 0.48%
>= 16.5.0-rc-1, < 16.10.5
16.10.5
GHSA-3738-p9x3-mv9r
XWiki Platform vulnerable to privilege escalation via properties with wiki syntax that are executed with wrong author
High
EPSS 0.79%
>= 13.10, < 13.10.11
13.10.11
GHSA-3738-p9x3-mv9r
XWiki Platform vulnerable to privilege escalation via properties with wiki syntax that are executed with wrong author
High
EPSS 0.79%
>= 14.5, < 14.10
14.10
GHSA-3738-p9x3-mv9r
XWiki Platform vulnerable to privilege escalation via properties with wiki syntax that are executed with wrong author
High
EPSS 0.79%
>= 14.0, < 14.4.7
14.4.7
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor