Skip to content

org.ops4j.pax.logging:pax-logging-log4j2 (Maven)

Advisories
16
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 2.0.12 or later clears every advisory below that has a fix.

Upgrade commands
maven
<dependency><groupId>org.ops4j.pax.logging</groupId><artifactId>pax-logging-log4j2</artifactId><version>2.0.12</version></dependency>
gradle
implementation("org.ops4j.pax.logging:pax-logging-log4j2:2.0.12")

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-7rjr-3q55-vv33
Incomplete fix for Apache Log4j vulnerability
Known exploited
Critical
EPSS 99.98%
>= 1.10.0, < 1.10.8
1.10.8
GHSA-7rjr-3q55-vv33
Incomplete fix for Apache Log4j vulnerability
Known exploited
Critical
EPSS 99.98%
>= 1.11.0, < 1.11.11
1.11.11
GHSA-7rjr-3q55-vv33
Incomplete fix for Apache Log4j vulnerability
Known exploited
Critical
EPSS 99.98%
>= 2.0.0, < 2.0.12
2.0.12
GHSA-7rjr-3q55-vv33
Incomplete fix for Apache Log4j vulnerability
Known exploited
Critical
EPSS 99.98%
>= 1.8.0, < 1.9.2
1.9.2
GHSA-7rjr-3q55-vv33
Incomplete fix for Apache Log4j vulnerability
Known exploited
Critical
EPSS 99.98%
>= 1.10.0, < 1.10.8
1.10.8
GHSA-7rjr-3q55-vv33
Incomplete fix for Apache Log4j vulnerability
Known exploited
Critical
EPSS 99.98%
>= 1.11.0, < 1.11.11
1.11.11
GHSA-7rjr-3q55-vv33
Incomplete fix for Apache Log4j vulnerability
Known exploited
Critical
EPSS 99.98%
>= 2.0.0, < 2.0.12
2.0.12
GHSA-7rjr-3q55-vv33
Incomplete fix for Apache Log4j vulnerability
Known exploited
Critical
EPSS 99.98%
>= 1.8.0, < 1.9.2
1.9.2
GHSA-jfh8-c2jp-5v3q
Remote code injection in Log4j
Known exploited
Critical
EPSS 100.00%
>= 2.0.0, < 2.0.11
2.0.11
GHSA-jfh8-c2jp-5v3q
Remote code injection in Log4j
Known exploited
Critical
EPSS 100.00%
>= 1.10.0, < 1.10.8
1.10.8
GHSA-jfh8-c2jp-5v3q
Remote code injection in Log4j
Known exploited
Critical
EPSS 100.00%
>= 1.11.0, < 1.11.10
1.11.10
GHSA-jfh8-c2jp-5v3q
Remote code injection in Log4j
Known exploited
Critical
EPSS 100.00%
>= 2.0.0, < 2.0.11
2.0.11
GHSA-jfh8-c2jp-5v3q
Remote code injection in Log4j
Known exploited
Critical
EPSS 100.00%
>= 1.8.0, < 1.9.2
1.9.2
GHSA-jfh8-c2jp-5v3q
Remote code injection in Log4j
Known exploited
Critical
EPSS 100.00%
>= 1.10.0, < 1.10.8
1.10.8
GHSA-jfh8-c2jp-5v3q
Remote code injection in Log4j
Known exploited
Critical
EPSS 100.00%
>= 1.11.0, < 1.11.10
1.11.10
GHSA-jfh8-c2jp-5v3q
Remote code injection in Log4j
Known exploited
Critical
EPSS 100.00%
>= 1.8.0, < 1.9.2
1.9.2
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor