org.kohsuke.stapler:stapler-parent (Maven)
Advisories
3
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 1.257.1 or later clears every advisory below that has a fix.
Upgrade commands
maven
<dependency><groupId>org.kohsuke.stapler</groupId><artifactId>stapler-parent</artifactId><version>1.257.1</version></dependency>gradle
implementation("org.kohsuke.stapler:stapler-parent:1.257.1")Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-6jfc-mc97-c7wg Missing Authorization in Jenkins |
Medium EPSS 1.65% |
< 1.257.1 | 1.257.1 |
| GHSA-5hfp-964w-5vgm Improper Limitation of a Pathname to a Restricted Directory in Jenkins |
Medium EPSS 3.26% |
< 1.250.2 | 1.250.2 |
| GHSA-6456-xjm5-g3pg Cross-site scripting vulnerability exists in Jenkins and Stapler Plugin |
Medium EPSS 0.89% |
< 1.250.1 | 1.250.1 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor