org.keycloak:keycloak-server-spi-private (Maven)
Advisories
7
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 26.6.3 or later clears every advisory below that has a fix.
Upgrade commands
maven
<dependency><groupId>org.keycloak</groupId><artifactId>keycloak-server-spi-private</artifactId><version>26.6.3</version></dependency>gradle
implementation("org.keycloak:keycloak-server-spi-private:26.6.3")Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-4q93-v92x-p89f Keycloak Vulnerable to Incorrect Authorization |
Medium EPSS 0.21% |
>= 26.5.0, < 26.6.3 | 26.6.3 |
| GHSA-4q93-v92x-p89f Keycloak Vulnerable to Incorrect Authorization |
Medium EPSS 0.21% |
<= 26.4.7 | No fix yet |
| GHSA-rr5q-3xwr-f323 Keycloak Vulnerable to Improper Validation of Specified Quantity in Input |
High EPSS 0.32% |
< 26.6.3 | 26.6.3 |
| GHSA-q35r-vvhv-vx5h Keycloak: Missing Role Enforcement on UMA 2.0 Permission Ticket Endpoint Leads to Information Disclosure |
Medium EPSS 0.33% |
< 26.5.6 | 26.5.6 |
| GHSA-x4p7-7chp-64hq Keycloak: Unauthorized authentication via disabled SAML Identity Provider |
High EPSS 0.44% |
< 26.5.5 | 26.5.5 |
| GHSA-f5h4-wmp5-xhg6 Client Spoofing within the Keycloak Device Authorisation Grant |
High EPSS 0.69% |
< 21.1.2 | 21.1.2 |
| GHSA-484q-784p-8m5h Cross-site Scripting in keycloak |
Medium EPSS 0.78% |
< 12.0.0 | 12.0.0 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor