org.jenkins-ci.main:cli (Maven)
Advisories
2
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 2.541 or later clears every advisory below that has a fix.
Upgrade commands
maven
<dependency><groupId>org.jenkins-ci.main</groupId><artifactId>cli</artifactId><version>2.541</version></dependency>gradle
implementation("org.jenkins-ci.main:cli:2.541")Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-9p56-p6mw-w8qc Jenkins has a Denial of service vulnerability in HTTP-based CLI |
High EPSS 0.56% |
>= 2.529, < 2.541 | 2.541 |
| GHSA-9p56-p6mw-w8qc Jenkins has a Denial of service vulnerability in HTTP-based CLI |
High EPSS 0.56% |
< 2.528.3 | 2.528.3 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor