org.igniterealtime.openfire:xmppserver (Maven)
Advisories
4
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 4.7.5 or later clears every advisory below that has a fix.
Upgrade commands
maven
<dependency><groupId>org.igniterealtime.openfire</groupId><artifactId>xmppserver</artifactId><version>4.7.5</version></dependency>gradle
implementation("org.igniterealtime.openfire:xmppserver:4.7.5")Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-gw42-f939-fhvm Administration Console authentication bypass in openfire xmppserver Known exploited |
High EPSS 100.00% |
>= 3.10.0, < 4.6.8 | 4.6.8 |
| GHSA-gw42-f939-fhvm Administration Console authentication bypass in openfire xmppserver Known exploited |
High EPSS 100.00% |
>= 4.7.0, < 4.7.5 | 4.7.5 |
| GHSA-gw42-f939-fhvm Administration Console authentication bypass in openfire xmppserver Known exploited |
High EPSS 100.00% |
>= 3.10.0, < 4.6.8 | 4.6.8 |
| GHSA-gw42-f939-fhvm Administration Console authentication bypass in openfire xmppserver Known exploited |
High EPSS 100.00% |
>= 4.7.0, < 4.7.5 | 4.7.5 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor