org.geoserver:gs-wfs (Maven)
Advisories
11
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 2.27.1 or later clears every advisory below that has a fix.
Upgrade commands
maven
<dependency><groupId>org.geoserver</groupId><artifactId>gs-wfs</artifactId><version>2.27.1</version></dependency>gradle
implementation("org.geoserver:gs-wfs:2.27.1")Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-jj54-8f66-c5pc [XBOW-025-068] XML External Entity (XXE) Processing Vulnerability in GeoServer WFS Service |
Critical EPSS 42.29% |
< 2.25.7 | 2.25.7 |
| GHSA-jj54-8f66-c5pc [XBOW-025-068] XML External Entity (XXE) Processing Vulnerability in GeoServer WFS Service |
Critical EPSS 42.29% |
>= 2.27.0, < 2.27.1 | 2.27.1 |
| GHSA-jj54-8f66-c5pc [XBOW-025-068] XML External Entity (XXE) Processing Vulnerability in GeoServer WFS Service |
Critical EPSS 42.29% |
>= 2.26.0, < 2.26.3 | 2.26.3 |
| GHSA-6jj6-gm7p-fcvv Remote Code Execution (RCE) vulnerability in geoserver Known exploited |
Critical EPSS 99.81% |
>= 2.24.0, < 2.24.4 | 2.24.4 |
| GHSA-6jj6-gm7p-fcvv Remote Code Execution (RCE) vulnerability in geoserver Known exploited |
Critical EPSS 99.81% |
>= 2.25.0, < 2.25.2 | 2.25.2 |
| GHSA-6jj6-gm7p-fcvv Remote Code Execution (RCE) vulnerability in geoserver Known exploited |
Critical EPSS 99.81% |
>= 2.23.0, < 2.23.6 | 2.23.6 |
| GHSA-6jj6-gm7p-fcvv Remote Code Execution (RCE) vulnerability in geoserver Known exploited |
Critical EPSS 99.81% |
< 2.22.6 | 2.22.6 |
| GHSA-6jj6-gm7p-fcvv Remote Code Execution (RCE) vulnerability in geoserver Known exploited |
Critical EPSS 99.81% |
>= 2.25.0, < 2.25.2 | 2.25.2 |
| GHSA-6jj6-gm7p-fcvv Remote Code Execution (RCE) vulnerability in geoserver Known exploited |
Critical EPSS 99.81% |
>= 2.24.0, < 2.24.4 | 2.24.4 |
| GHSA-6jj6-gm7p-fcvv Remote Code Execution (RCE) vulnerability in geoserver Known exploited |
Critical EPSS 99.81% |
>= 2.23.0, < 2.23.6 | 2.23.6 |
| GHSA-6jj6-gm7p-fcvv Remote Code Execution (RCE) vulnerability in geoserver Known exploited |
Critical EPSS 99.81% |
< 2.22.6 | 2.22.6 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor