org.geoserver:gs-main (Maven)
Advisories
6
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 2.27.3 or later clears every advisory below that has a fix.
Upgrade commands
maven
<dependency><groupId>org.geoserver</groupId><artifactId>gs-main</artifactId><version>2.27.3</version></dependency>gradle
implementation("org.geoserver:gs-main:2.27.3")Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-wf6j-gr27-g7ch GeoServer has a Server-Side Template Injection (SSTI) vulnerability in processing FreeMarker templates |
High | < 2.27.0 | 2.27.0 |
| GHSA-x4r9-gmw3-hxww GeoServer has a Server-Side Request Forgery (SSRF) Vulnerability in its XML Entity Resolution |
High EPSS 0.29% |
< 2.26.4 | 2.26.4 |
| GHSA-x4r9-gmw3-hxww GeoServer has a Server-Side Request Forgery (SSRF) Vulnerability in its XML Entity Resolution |
High EPSS 0.29% |
>= 2.27.0, < 2.27.3 | 2.27.3 |
| GHSA-j59v-vgcr-hxvf GeoServer's Server Status shows sensitive environmental variables and Java properties |
Medium EPSS 0.40% |
>= 2.10.0, < 2.24.4 | 2.24.4 |
| GHSA-j59v-vgcr-hxvf GeoServer's Server Status shows sensitive environmental variables and Java properties |
Medium EPSS 0.40% |
>= 2.25.0, < 2.25.1 | 2.25.1 |
| GHSA-8hmh-mhqv-7638 PartialBufferOutputStream2 flush issues Withdrawn |
Medium EPSS 0.93% |
< 1.6.1 | 1.6.1 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor