Skip to content

org.geoserver.web:gs-web-app (Maven)

Advisories
37
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 2.27.3 or later clears every advisory below that has a fix.

Upgrade commands
maven
<dependency><groupId>org.geoserver.web</groupId><artifactId>gs-web-app</artifactId><version>2.27.3</version></dependency>
gradle
implementation("org.geoserver.web:gs-web-app:2.27.3")

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-wf6j-gr27-g7ch
GeoServer has a Server-Side Template Injection (SSTI) vulnerability in processing FreeMarker templates
High
< 2.27.0
2.27.0
GHSA-x4r9-gmw3-hxww
GeoServer has a Server-Side Request Forgery (SSRF) Vulnerability in its XML Entity Resolution
High
EPSS 0.29%
>= 2.27.0, < 2.27.3
2.27.3
GHSA-x4r9-gmw3-hxww
GeoServer has a Server-Side Request Forgery (SSRF) Vulnerability in its XML Entity Resolution
High
EPSS 0.29%
< 2.26.4
2.26.4
GHSA-7qmg-grcp-qf25
GeoServer has an arbitrary file write vulnerability in its Master Password Dump Page
High
EPSS 0.62%
< 2.26.4
2.26.4
GHSA-7qmg-grcp-qf25
GeoServer has an arbitrary file write vulnerability in its Master Password Dump Page
High
EPSS 0.62%
>= 2.27.0, < 2.27.3
2.27.3
GHSA-fjf5-xgmq-5525
GeoServer is vulnerable to Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature
Known exploited
Critical
EPSS 61.17%
< 2.25.6
2.25.6
GHSA-fjf5-xgmq-5525
GeoServer is vulnerable to Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature
Known exploited
Critical
EPSS 61.17%
>= 2.26.0, < 2.26.2
2.26.2
GHSA-fjf5-xgmq-5525
GeoServer is vulnerable to Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature
Known exploited
Critical
EPSS 61.17%
< 2.25.6
2.25.6
GHSA-fjf5-xgmq-5525
GeoServer is vulnerable to Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature
Known exploited
Critical
EPSS 61.17%
>= 2.26.0, < 2.26.2
2.26.2
GHSA-w66h-j855-qr72
GeoServer has a Reflected Cross-Site Scripting (XSS) vulnerability in its WMS GetFeatureInfo HTML format
Medium
EPSS 0.32%
< 2.25.0
2.25.0
GHSA-jj54-8f66-c5pc
[XBOW-025-068] XML External Entity (XXE) Processing Vulnerability in GeoServer WFS Service
Critical
EPSS 42.29%
>= 2.27.0, < 2.27.1
2.27.1
GHSA-jj54-8f66-c5pc
[XBOW-025-068] XML External Entity (XXE) Processing Vulnerability in GeoServer WFS Service
Critical
EPSS 42.29%
< 2.25.7
2.25.7
GHSA-jj54-8f66-c5pc
[XBOW-025-068] XML External Entity (XXE) Processing Vulnerability in GeoServer WFS Service
Critical
EPSS 42.29%
>= 2.26.0, < 2.26.3
2.26.3
GHSA-gr67-pwcv-76gf
GeoServer Infinite Loop Vulnerability in Jiffle process
High
EPSS 0.51%
< 2.25.7
2.25.7
GHSA-gr67-pwcv-76gf
GeoServer Infinite Loop Vulnerability in Jiffle process
High
EPSS 0.51%
>= 2.26.0, < 2.26.3
2.26.3
GHSA-h86g-x8mm-78m5
GeoServer Missing Authorization on REST API Index
Medium
EPSS 1.15%
>= 2.26.0, < 2.26.3
2.26.3
GHSA-h86g-x8mm-78m5
GeoServer Missing Authorization on REST API Index
Medium
EPSS 1.15%
< 2.25.6
2.25.6
GHSA-r4hf-r8gj-jgw2
Coverage REST API Server Side Request Forgery
Medium
EPSS 0.37%
< 2.26.0
2.26.0
GHSA-jm79-7xhw-6f6f
GWC Home Page communicate version and revision information
High
EPSS 0.44%
< 2.25.6
2.25.6
GHSA-jm79-7xhw-6f6f
GWC Home Page communicate version and revision information
High
EPSS 0.44%
>= 2.26.0, < 2.26.2
2.26.2
GHSA-mc43-4fqr-c965
GeoServer has improper ENTITY_RESOLUTION_ALLOWLIST URI validation in XML Processing (SSRF)
High
EPSS 0.30%
< 2.25.0
2.25.0
GHSA-6pfc-w86r-54q6
Welcome and About GeoServer pages communicate version and revision information
Medium
EPSS 0.70%
>= 2.0.0, < 2.25.1
2.25.1
GHSA-6jj6-gm7p-fcvv
Remote Code Execution (RCE) vulnerability in geoserver
Known exploited
Critical
EPSS 99.81%
>= 2.23.0, < 2.23.6
2.23.6
GHSA-6jj6-gm7p-fcvv
Remote Code Execution (RCE) vulnerability in geoserver
Known exploited
Critical
EPSS 99.81%
>= 2.25.0, < 2.25.2
2.25.2
GHSA-6jj6-gm7p-fcvv
Remote Code Execution (RCE) vulnerability in geoserver
Known exploited
Critical
EPSS 99.81%
< 2.22.6
2.22.6
GHSA-6jj6-gm7p-fcvv
Remote Code Execution (RCE) vulnerability in geoserver
Known exploited
Critical
EPSS 99.81%
>= 2.24.0, < 2.24.4
2.24.4
GHSA-6jj6-gm7p-fcvv
Remote Code Execution (RCE) vulnerability in geoserver
Known exploited
Critical
EPSS 99.81%
>= 2.25.0, < 2.25.2
2.25.2
GHSA-6jj6-gm7p-fcvv
Remote Code Execution (RCE) vulnerability in geoserver
Known exploited
Critical
EPSS 99.81%
>= 2.23.0, < 2.23.6
2.23.6
GHSA-6jj6-gm7p-fcvv
Remote Code Execution (RCE) vulnerability in geoserver
Known exploited
Critical
EPSS 99.81%
< 2.22.6
2.22.6
GHSA-6jj6-gm7p-fcvv
Remote Code Execution (RCE) vulnerability in geoserver
Known exploited
Critical
EPSS 99.81%
>= 2.24.0, < 2.24.4
2.24.4
GHSA-j59v-vgcr-hxvf
GeoServer's Server Status shows sensitive environmental variables and Java properties
Medium
EPSS 0.40%
>= 2.10.0, < 2.24.4
2.24.4
GHSA-j59v-vgcr-hxvf
GeoServer's Server Status shows sensitive environmental variables and Java properties
Medium
EPSS 0.40%
>= 2.25.0, < 2.25.1
2.25.1
GHSA-jhqx-5v5g-mpf3
Classpath resource disclosure in GWC Web Resource API on Windows / Tomcat
High
EPSS 0.76%
< 2.23.5
2.23.5
GHSA-jhqx-5v5g-mpf3
Classpath resource disclosure in GWC Web Resource API on Windows / Tomcat
High
EPSS 0.76%
>= 2.24.0, < 2.24.3
2.24.3
GHSA-cqpc-x2c6-2gmf
Unsecured WMS dynamic styling sld=<url> parameter affords blind unauthenticated SSRF
Medium
EPSS 0.63%
>= 2.23.0, < 2.23.2
2.23.2
GHSA-cqpc-x2c6-2gmf
Unsecured WMS dynamic styling sld=<url> parameter affords blind unauthenticated SSRF
Medium
EPSS 0.63%
< 2.22.5
2.22.5
GHSA-8hmh-mhqv-7638
PartialBufferOutputStream2 flush issues
Withdrawn
Medium
EPSS 0.93%
< 1.6.1
1.6.1
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor