Skip to content

org.apache.tomcat:tomcat-tribes (Maven)

Advisories
14
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 11.0.21 or later clears every advisory below that has a fix.

Upgrade commands
maven
<dependency><groupId>org.apache.tomcat</groupId><artifactId>tomcat-tribes</artifactId><version>11.0.21</version></dependency>
gradle
implementation("org.apache.tomcat:tomcat-tribes:11.0.21")

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-x4m4-345f-5h5g
Apache Tomcat vulnerable to Insertion of Sensitive Information into Log File
High
EPSS 0.45%
>= 11.0.0-M1, < 11.0.21
11.0.21
GHSA-x4m4-345f-5h5g
Apache Tomcat vulnerable to Insertion of Sensitive Information into Log File
High
EPSS 0.45%
>= 10.1.0-M1, < 10.1.54
10.1.54
GHSA-x4m4-345f-5h5g
Apache Tomcat vulnerable to Insertion of Sensitive Information into Log File
High
EPSS 0.45%
>= 9.0.13, < 9.0.117
9.0.117
GHSA-69r9-qgr7-g2wj
Apache Tomcat Missing Encryption of Sensitive Data vulnerability
Known exploited
High
EPSS 98.50%
No fix yet
GHSA-69r9-qgr7-g2wj
Apache Tomcat Missing Encryption of Sensitive Data vulnerability
Known exploited
High
EPSS 98.50%
No fix yet
GHSA-69r9-qgr7-g2wj
Apache Tomcat Missing Encryption of Sensitive Data vulnerability
Known exploited
High
EPSS 98.50%
No fix yet
GHSA-69r9-qgr7-g2wj
Apache Tomcat Missing Encryption of Sensitive Data vulnerability
Known exploited
High
EPSS 98.50%
>= 11.0.20, < 11.0.21
11.0.21
GHSA-69r9-qgr7-g2wj
Apache Tomcat Missing Encryption of Sensitive Data vulnerability
Known exploited
High
EPSS 98.50%
>= 10.1.53, < 10.1.54
10.1.54
GHSA-69r9-qgr7-g2wj
Apache Tomcat Missing Encryption of Sensitive Data vulnerability
Known exploited
High
EPSS 98.50%
>= 9.0.116, < 9.0.117
9.0.117
GHSA-h468-7pvh-8vr8
Apache Tomcat: Padding Oracle vulnerability in EncryptInterceptor
High
EPSS 8.85%
>= 8.5.38, <= 8.5.100
No fix yet
GHSA-h468-7pvh-8vr8
Apache Tomcat: Padding Oracle vulnerability in EncryptInterceptor
High
EPSS 8.85%
>= 7.0.100, <= 7.0.109
No fix yet
GHSA-h468-7pvh-8vr8
Apache Tomcat: Padding Oracle vulnerability in EncryptInterceptor
High
EPSS 8.85%
>= 11.0.0-M1, < 11.0.20
11.0.20
GHSA-h468-7pvh-8vr8
Apache Tomcat: Padding Oracle vulnerability in EncryptInterceptor
High
EPSS 8.85%
>= 10.1.50, < 10.1.53
10.1.53
GHSA-h468-7pvh-8vr8
Apache Tomcat: Padding Oracle vulnerability in EncryptInterceptor
High
EPSS 8.85%
>= 9.0.13, < 9.0.116
9.0.116
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor