Skip to content

org.apache.struts:struts2-rest-plugin (Maven)

Advisories
6
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 2.5.13 or later clears every advisory below that has a fix.

Upgrade commands
maven
<dependency><groupId>org.apache.struts</groupId><artifactId>struts2-rest-plugin</artifactId><version>2.5.13</version></dependency>
gradle
implementation("org.apache.struts:struts2-rest-plugin:2.5.13")

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-j7h6-xr7g-m2c5
Code injection in Apache Struts
High
EPSS 8.40%
>= 2.0.0, < 2.3.15.2
2.3.15.2
GHSA-4prj-vw9j-v6pr
Arbitrary code execution in Apache Struts 2
Critical
EPSS 16.74%
>= 2.3.19, < 2.3.29
2.3.29
GHSA-gg9m-fj3v-r58c
REST Plugin in Apache Struts uses an XStreamHandler with an instance of XStream for deserialization without any type filtering
Known exploited
High
EPSS 99.40%
>= 2.5.0, < 2.5.13
2.5.13
GHSA-gg9m-fj3v-r58c
REST Plugin in Apache Struts uses an XStreamHandler with an instance of XStream for deserialization without any type filtering
Known exploited
High
EPSS 99.40%
>= 2.1.1, < 2.3.34
2.3.34
GHSA-gg9m-fj3v-r58c
REST Plugin in Apache Struts uses an XStreamHandler with an instance of XStream for deserialization without any type filtering
Known exploited
High
EPSS 99.40%
>= 2.5.0, < 2.5.13
2.5.13
GHSA-gg9m-fj3v-r58c
REST Plugin in Apache Struts uses an XStreamHandler with an instance of XStream for deserialization without any type filtering
Known exploited
High
EPSS 99.40%
>= 2.1.1, < 2.3.34
2.3.34
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor