org.apache.jspwiki:jspwiki-war (Maven)
Advisories
5
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 2.12.0 or later clears every advisory below that has a fix.
Upgrade commands
maven
<dependency><groupId>org.apache.jspwiki</groupId><artifactId>jspwiki-war</artifactId><version>2.12.0</version></dependency>gradle
implementation("org.apache.jspwiki:jspwiki-war:2.12.0")Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-qvq8-cw7f-m7m4 Apache JSPWiki vulnerable to cross-site scripting on several plugins |
Medium EPSS 1.16% |
< 2.12.0 | 2.12.0 |
| GHSA-p2r4-rpj8-m2p9 Cross-site Scripting in Apache JSPWiki |
Medium EPSS 2.91% |
< 2.11.0.M5 | 2.11.0.M5 |
| GHSA-hp5r-mhgp-56c9 Cross-site Scriptin in JSPWiki |
Medium EPSS 4.94% |
>= 2.9.0, < 2.11.0.M4 | 2.11.0.M4 |
| GHSA-cj6j-32rg-45r2 Cross-site Scripting in JSPWiki |
Medium EPSS 4.68% |
>= 2.9.0, < 2.11.0.M4 | 2.11.0.M4 |
| GHSA-cxx2-fp39-rf3r Cross-Site Scripting in JSPWiki |
Medium EPSS 4.72% |
>= 2.9.0, < 2.11.0.M4 | 2.11.0.M4 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor