org.apache.activemq:activemq-web (Maven)
Advisories
4
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 6.2.6 or later clears every advisory below that has a fix.
Upgrade commands
maven
<dependency><groupId>org.apache.activemq</groupId><artifactId>activemq-web</artifactId><version>6.2.6</version></dependency>gradle
implementation("org.apache.activemq:activemq-web:6.2.6")Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-8wm6-6fqh-phmc Apache ActiveMQ, Apache ActiveMQ Web have a Cross-site Scripting issue |
Medium EPSS 1.02% |
< 5.19.7 | 5.19.7 |
| GHSA-8wm6-6fqh-phmc Apache ActiveMQ, Apache ActiveMQ Web have a Cross-site Scripting issue |
Medium EPSS 1.02% |
>= 6.0.0, < 6.2.6 | 6.2.6 |
| GHSA-h2h4-5m64-m273 Apache ActiveMQ: Improper validation and restriction of a classpath path name |
Medium EPSS 0.42% |
< 5.19.3 | 5.19.3 |
| GHSA-h2h4-5m64-m273 Apache ActiveMQ: Improper validation and restriction of a classpath path name |
Medium EPSS 0.42% |
>= 6.0.0, < 6.2.2 | 6.2.2 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor