wisp (Hex)
Advisories
4
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 2.2.2 or later clears every advisory below that has a fix.
Upgrade commands
mix
{:wisp, "~> 2.2.2"} # then: mix deps.update wispKnown vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| EEF-CVE-2026-32145 Multipart form body parser bypasses body size limits in wisp |
High EPSS 0.63% |
>= 0.2.0, < 2.2.2 | 2.2.2 |
| EEF-CVE-2026-32145 Multipart form body parser bypasses body size limits in wisp |
High EPSS 0.63% |
< 2.2.2 | 2.2.2 |
| EEF-CVE-2026-28807 Path Traversal in wisp.serve_static allows arbitrary file read |
High EPSS 1.10% |
>= 2.1.1, < 2.2.1 | 2.2.1 |
| EEF-CVE-2026-28807 Path Traversal in wisp.serve_static allows arbitrary file read |
High EPSS 1.10% |
>= 2.1.1, < 2.2.1 | 2.2.1 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor