rabbit_common (Hex)
Advisories
8
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 3.12.11 or later clears every advisory below that has a fix.
Upgrade commands
mix
{:rabbit_common, "~> 3.12.11"} # then: mix deps.update rabbit_commonKnown vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-pj33-75x5-32j4 RabbitMQ HTTP API's queue deletion endpoint does not verify that the user has a required permission |
Medium EPSS 0.36% |
>= 3.12.7, < 3.12.11 | 3.12.11 |
| GHSA-w6cq-9cf4-gqpg RabbitMQ vulnerable to Denial of Service by publishing large messages over the HTTP API |
Medium EPSS 1.32% |
>= 3.11.0, < 3.11.24 | 3.11.24 |
| GHSA-w6cq-9cf4-gqpg RabbitMQ vulnerable to Denial of Service by publishing large messages over the HTTP API |
Medium EPSS 1.32% |
>= 3.12.0, < 3.12.7 | 3.12.7 |
| GHSA-v9gv-xp36-jgj8 RabbitMQ has predictable credential obfuscation seed value used in Shovel and Federation plugins |
High EPSS 0.40% |
>= 3.8.0, < 3.8.32 | 3.8.32 |
| GHSA-v9gv-xp36-jgj8 RabbitMQ has predictable credential obfuscation seed value used in Shovel and Federation plugins |
High EPSS 0.40% |
>= 3.9.0, < 3.9.18 | 3.9.18 |
| GHSA-v9gv-xp36-jgj8 RabbitMQ has predictable credential obfuscation seed value used in Shovel and Federation plugins |
High EPSS 0.40% |
>= 3.10.0, < 3.10.2 | 3.10.2 |
| GHSA-9pf7-f47q-mwpq Cross-site Scripting in RabbitMQ |
Low EPSS 0.80% |
>= 3.8.0, < 3.8.1 | 3.8.1 |
| GHSA-9pf7-f47q-mwpq Cross-site Scripting in RabbitMQ |
Low EPSS 0.80% |
>= 3.7.0, < 3.7.20 | 3.7.20 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor