phoenix_html (Hex)
Advisories
3
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 4.4.0 or later clears every advisory below that has a fix.
Upgrade commands
mix
{:phoenix_html, "~> 4.4.0"} # then: mix deps.update phoenix_htmlKnown vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| EEF-CVE-2026-117645 Phoenix.HTML vulnerable to attribute injection via unvalidated attribute names in attributes_escape/1 |
Not rated yet EPSS 0.32% |
>= 1.0.0, < 3.3.5>= 4.0.0, < 4.4.0 | 3.3.54.4.0 |
| GHSA-5g2h-9x5v-5h3x phoenix_html allows Cross-site Scripting in HEEx class attributes |
Medium EPSS 0.43% |
< 3.0.4 | 3.0.4 |
| GHSA-5g2h-9x5v-5h3x phoenix_html allows Cross-site Scripting in HEEx class attributes |
Medium EPSS 0.43% |
< 3.0.4 | 3.0.4 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor