github.com/nats-io/jwt (Go)
Advisories
7
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 1.2.3-0.20210314221642-a826c77dc9d2 or later clears every advisory below that has a fix.
Upgrade commands
go
go get github.com/nats-io/jwt@v1.2.3-0.20210314221642-a826c77dc9d2 && go mod tidyKnown vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-9r5x-fjv3-q6h4 nats-io/jwt not enforcing checking of Import token permissions |
High EPSS 1.45% |
< 1.2.3-0.20210314221642-a826c77dc9d2 | 1.2.3-0.20210314221642-a826c77dc9d2 |
| GHSA-9r5x-fjv3-q6h4 nats-io/jwt not enforcing checking of Import token permissions |
High EPSS 1.45% |
<= 1.2.2 | No fix yet |
| GHSA-9r5x-fjv3-q6h4 nats-io/jwt not enforcing checking of Import token permissions |
High EPSS 1.45% |
< 1.2.3-0.20210314221642-a826c77dc9d2 | 1.2.3-0.20210314221642-a826c77dc9d2 |
| GHSA-hmm9-r2m2-qg9w Nil dereference in NATS JWT, DoS of nats-server |
High EPSS 2.16% |
< 1.1.0 | 1.1.0 |
| GHSA-hmm9-r2m2-qg9w Nil dereference in NATS JWT, DoS of nats-server |
High EPSS 2.16% |
< 1.1.0 | 1.1.0 |
| GHSA-2c64-vj8g-vwrq Incorrect handling of credential expiry by /nats-io/nats-server |
Critical EPSS 2.33% |
< 1.1.0 | 1.1.0 |
| GHSA-2c64-vj8g-vwrq Incorrect handling of credential expiry by /nats-io/nats-server |
Critical EPSS 2.33% |
< 1.1.0 | 1.1.0 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor