RUSTSEC-2026-0219 GHSA-xg7c-246g-6qpv
Remote Denial of Service via malformed NIP-04 IV
- Severity
- 7.5 / 10
- High · CVSS 3.1
- Exploit chance (EPSS)
- —
- No score published
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- —
- Not classified
- Fix
0.45.0-alpha.6- Upgrade nostr to this version or later
Description
The nostr crate did not validate the length of the initialization vector
decoded from the ?iv= portion of a NIP-04 encrypted message.
The decoded IV was converted from a byte slice to the 16-byte AES-CBC IV type
using a conversion that asserts the slice length. As a result, an IV whose
decoded length was not exactly 16 bytes caused a panic before ciphertext
decryption. For example, ?iv=AAAA decodes to a three-byte IV and triggers the
panic.
Applications that decrypt untrusted NIP-04 content are affected. The issue is also reachable through NIP-47 (Nostr Wallet Connect), where response and notification events from a malicious or compromised wallet service are passed to NIP-04 decryption. If the panic is not isolated, a crafted event can terminate the application or disrupt message processing, causing a denial of service.
The issue does not affect confidentiality or integrity.
The flaw was corrected by converting the decoded IV to [u8; 16] using a
checked conversion. Invalid IV lengths now return a Malformed error instead of
panicking.
Credit
Discovered and responsibly disclosed by Muhammed Shekho (mhd-shekho.com).
Affected versions
crates.io
| Package | Vulnerable | Fixed in |
|---|---|---|
| nostr | >= 0.0.0-0, < 0.44.6>= 0.45.0-alpha.1, < 0.45.0-alpha.6 |
0.44.60.45.0-alpha.6 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
nostr crates.io → 0.45.0-alpha.6
- cargo
cargo update -p nostr --precise 0.45.0-alpha.6
Severity breakdown
CVSS 3.1 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- High
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| RUSTSEC-2026-0230 Empty NIP-50 search filters can panic | High | Also affects nostr |
| RUSTSEC-2026-0229 NIP-98 authorization parsing permits resource exhaustion | High | Also affects nostr |
| RUSTSEC-2026-0226 Wallet event parsers accept unauthenticated events | High | Also affects nostr |
| RUSTSEC-2026-0227 NIP-44 v2 decryption permits resource exhaustion | High | Also affects nostr |
| RUSTSEC-2026-0225 Debug output exposes NIP-46 and NIP-60 credentials | Medium | Also affects nostr |
| RUSTSEC-2026-0228 NIP-04 parsing amplifies malformed ciphertext memory use | Medium | Also affects nostr |
| RUSTSEC-2026-0216 Remote Denial of Service via malformed NIP‑44 v2 payload | High | Also affects nostr |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor