PYSEC-2009-17 CVE-2009-0662 GHSA-pq3x-96c3-xgjg PYSEC-2026-739
Moderate severity vulnerability that affects Products.PlonePAS
- Severity
- Medium
- The publisher's own rating, not a CVSS score
- Exploit chance (EPSS)
- 0.97%
- Chance of exploitation in the next 30 days. Higher than 61.91% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-287 Improper Authentication
- Fix
3.9- Upgrade products-plonepas to this version or later
Description
The PlonePAS product 3.x before 3.9 and 3.2.x before 3.2.2, a product for Plone, does not properly handle the login form, which allows remote authenticated users to acquire the identity of an arbitrary user via unspecified vectors.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| plone | >= 3.0, <= 3.1<= 3.2<= 3.3<= 3.4<= 3.5 |
No fix yet |
| products-plonepas | >= 3, < 3.9 |
3.9 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
products-plonepas PyPI → 3.9
- pip
pip install --upgrade "products-plonepas>=3.9"- poetry
poetry add "products-plonepas>=3.9"- uv
uv add "products-plonepas>=3.9"
Weakness
CWE-287: Improper Authentication
When an actor claims to have a given identity, the product does not prove or insufficiently proves that the claim is correct.
How to prevent it
- Architecture and Design: Use an authentication framework or library such as the OWASP ESAPI Authentication feature.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-xg5p-8wg5-rhxm Phone information disclosure vulnerability | High | Also affects plone |
| GHSA-5xfx-55x4-j223 Cross-Frame Scripting vulnerability has been found on Plone CMS | High | Also affects plone |
| GHSA-47p5-p3jw-w78w Server-Side Request Forgery in Plone CMS | High | Also affects plone |
| GHSA-cvwc-g7fw-7xrj Plone XSS Vulnerability | Medium | Also affects plone |
| GHSA-pwgm-jvqv-6v8p Plone anonymous access to sub-objects in CMFEditions where KwAsAttributes classes were publishable | High | Also affects plone |
| GHSA-46f9-f8jm-mw2x Plone Cross-site Scripting vulnerability in the LiveSearch module | Medium | Also affects plone |
| GHSA-hjp5-hv33-q58g Plone credentials stored in session cookie | Medium | Also affects plone |
| GHSA-593c-j348-f3gv Plone Improper Session Management | High | Also affects plone |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor