Skip to content

GHSA-xrqm-fpgr-6hhx BIT-tensorflow-2021-41202 CVE-2021-41202 PYSEC-2021-395 PYSEC-2021-612 PYSEC-2021-810

Overflow/crash in `tf.range`

Medium PyPI
Severity
0.0 / 10
Medium · CVSS 4.0
Exploit chance (EPSS)
0.21%
Chance of exploitation in the next 30 days. Higher than 11.10% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-681 Incorrect Conversion between Numeric Types
Fix
Available
3 packages have a fixed version

Description

Impact

While calculating the size of the output within the tf.range kernel, there is a conditional statement of type int64 = condition ? int64 : double. Due to C++ implicit conversion rules, both branches of the condition will be cast to double and the result would be truncated before the assignment. This result in overflows:

import tensorflow as tf

tf.sparse.eye(num_rows=9223372036854775807, num_columns=None)

Similarly, tf.range would result in crashes due to overflows if the start or end point are too large.

import tensorflow as tf

tf.range(start=-1e+38, limit=1)

Patches

We have patched the issue in GitHub commits 6d94002a09711d297dbba90390d5482b76113899 (merging #51359) and 1b0e0ec27e7895b9985076eab32445026ae5ca94 (merging #51711).

The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.

For more information

Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Attribution

This vulnerability has been reported externally via GitHub issue, GitHub issue and GitHub issue.

Affected versions

PyPI

PackageVulnerableFixed in
tensorflow
>= 2.6.0, < 2.6.1
2.6.1
tensorflow
>= 2.5.0, < 2.5.2
2.5.2
tensorflow
< 2.4.4
2.4.4
tensorflow
< 2.4.4
>= 2.5.0, < 2.5.2
>= 2.6.0, < 2.6.1
>= 2.7.0rc0, < 2.7.0
2.4.4
2.5.2
2.6.1
2.7.0
tensorflow-cpu
>= 2.6.0, < 2.6.1
2.6.1
tensorflow-cpu
>= 2.5.0, < 2.5.2
2.5.2
tensorflow-cpu
< 2.4.4
2.4.4
tensorflow-cpu
< 2.4.4
>= 2.5.0, < 2.5.2
>= 2.6.0, < 2.6.1
>= 2.7.0rc0, < 2.7.0
2.4.4
2.5.2
2.6.1
2.7.0
tensorflow-gpu
>= 2.6.0, < 2.6.1
2.6.1
tensorflow-gpu
>= 2.5.0, < 2.5.2
2.5.2
tensorflow-gpu
< 2.4.4
2.4.4
tensorflow-gpu
< 2.4.4
>= 2.5.0, < 2.5.2
>= 2.6.0, < 2.6.1
>= 2.7.0rc0, < 2.7.0
2.4.4
2.5.2
2.6.1
2.7.0

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

tensorflow PyPI → 2.6.1

pip
pip install --upgrade "tensorflow>=2.6.1"
poetry
poetry add "tensorflow>=2.6.1"
uv
uv add "tensorflow>=2.6.1"

tensorflow-cpu PyPI → 2.6.1

pip
pip install --upgrade "tensorflow-cpu>=2.6.1"
poetry
poetry add "tensorflow-cpu>=2.6.1"
uv
uv add "tensorflow-cpu>=2.6.1"

tensorflow-gpu PyPI → 2.6.1

pip
pip install --upgrade "tensorflow-gpu>=2.6.1"
poetry
poetry add "tensorflow-gpu>=2.6.1"
uv
uv add "tensorflow-gpu>=2.6.1"

Severity breakdown

CVSS 4.0 0.0

CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Attack vector
Local
Attack complexity
Low
Attack requirements
None
Privileges required
Low
User interaction
None
Confidentiality (vulnerable system)
None
Integrity (vulnerable system)
None
Availability (vulnerable system)
High
Confidentiality (subsequent systems)
None
Integrity (subsequent systems)
None
Availability (subsequent systems)
None

CVSS 3.1 5.5

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Attack vector
Local
Attack complexity
Low
Privileges required
Low
User interaction
None
Scope
Unchanged
Confidentiality
None
Integrity
None
Availability
High

Weakness

CWE-681: Incorrect Conversion between Numeric Types

When converting from one data type to another, such as long to integer, data can be omitted or translated in a way that produces unexpected values. If the resulting values are used in a sensitive context, then dangerous behaviors may occur.

How to prevent it
  • Implementation: Avoid making conversion between numeric types. Always check for the allowed ranges.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-gjh7-xx4r-x345
TensorFlow has segfault in array_ops.upper_bound
High Also affects tensorflow
GHSA-fxgc-95xx-grvq
TensorFlow Denial of Service vulnerability
Medium Also affects tensorflow
GHSA-93vr-9q9m-pj8p
TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch
High Also affects tensorflow
GHSA-qjqc-vqcf-5qvj
TensorFlow vulnerable to seg fault in `tf.raw_ops.Print`
High Also affects tensorflow
GHSA-7jvm-xxmr-v5cw
TensorFlow vulnerable to integer overflow in EditDistance
High Also affects tensorflow
GHSA-64jg-wjww-7c5w
TensorFlow has Null Pointer Error in TensorArrayConcatV2
High Also affects tensorflow
GHSA-6hg6-5c2q-7rcr
TensorFlow has Heap-buffer-overflow in AvgPoolGrad
High Also affects tensorflow
GHSA-558h-mq8x-7q9g
TensorFlow has Null Pointer Error in SparseSparseMaximum
High Also affects tensorflow
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor