GHSA-xqxm-2rpm-3889 CVE-2022-21683 PYSEC-2022-13
Comment reply notifications sent to incorrect users
- Severity
- 0.0 / 10
- Low · CVSS 4.0
- Exploit chance (EPSS)
- 0.97%
- Chance of exploitation in the next 30 days. Higher than 61.89% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor
- Fix
2.15.2- Upgrade wagtail to this version or later
Description
Impact
When notifications for new replies in comment threads are sent, they are sent to all users who have replied or commented anywhere on the site, rather than only in the relevant threads. This means that a user could listen in to new comment replies on pages they have not had editing access to, as long as they have left a comment or reply somewhere on the site.
Patches
A patched version has been released as Wagtail 2.15.2 (for the current LTS), which restores the intended behaviour - to send notifications for new replies to the participants in the active thread only (editing permissions are not considered).
Workarounds
New comments can be disabled by setting WAGTAILADMIN_COMMENTS_ENABLED = False in the Django settings file.
Acknowledgements
Many thanks to Ihor Marhitych for identifying this issue.
For more information
If you have any questions or comments about this advisory:
- Visit Wagtail's support channels
- Email us at security@wagtail.io (if you wish to send encrypted email, the public key ID is
0x6ba1e1a86e0f8ce8)
Affected versions
PyPI
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
wagtail PyPI → 2.15.2
- pip
pip install --upgrade "wagtail>=2.15.2"- poetry
poetry add "wagtail>=2.15.2"- uv
uv add "wagtail>=2.15.2"
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
- Attack vector
- Network
- Attack complexity
- Low
- Attack requirements
- None
- Privileges required
- Low
- User interaction
- Passive
- Confidentiality (vulnerable system)
- Low
- Integrity (vulnerable system)
- None
- Availability (vulnerable system)
- None
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.1 3.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- Required
- Scope
- Unchanged
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Weakness
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information.
How to prevent it
- Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-jm5p-837g-rv8g Wagtail: Improper restriction handling on Page translation API endpoint | Medium | Also affects wagtail |
| GHSA-x5cx-w6p2-mxf2 Wagtail: Improper permission handling when copying snippets | Medium | Also affects wagtail |
| GHSA-c2xx-cjmh-9q8f Wagtail: Improper restriction handling on descendant collections in Documents and Images API | Medium | Also affects wagtail |
| GHSA-92hv-j533-69wc Wagtail: Identification of documents by SHA1 hash | Low | Also affects wagtail |
| GHSA-3vrh-m9w7-v94f Wagtail: Improper restriction handling on Pages admin API | Medium | Also affects wagtail |
| GHSA-23m2-mghx-vqmf Wagtail: Reflected XSS in dynamic image URL generator view | High | Also affects wagtail |
| GHSA-8634-mr4j-r72c Wagtail: Pages translations can be created without page permissions when using simple_translation | Medium | Also affects wagtail |
| GHSA-r6p4-grq7-xm4m Wagtail: Improper permission handling in image preview | Medium | Also affects wagtail |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor