GHSA-xh35-w7wg-95v3 CVE-2024-21648
XWiki has no right protection on rollback action
- Severity
- 8.0 / 10
- High · CVSS 3.1
- Exploit chance (EPSS)
- 0.51%
- Chance of exploitation in the next 30 days. Higher than 43.69% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-274 Improper Handling of Insufficient Privileges
- Fix
- Available
- 2 packages have a fixed version
Description
Impact
The rollback action is missing a right protection: it means that a user can rollback to a previous version of the page to gain rights they don't have anymore. This vulnerability impacts all version of XWiki since rollback action is available.
Patches
The problem has been patched in XWiki 14.10.16, 15.5.3 and 15.8-rc-1 by ensuring that the rights are checked before performing the rollback.
Workarounds
There's no workaround for this vulnerability, except paying attention to delete old versions of documents that could allow users to gain more rights.
References
- JIRA ticket: https://jira.xwiki.org/browse/XWIKI-21257
- Commit: 4de72875ca49602796165412741033bfdbf1e680
For more information
If you have any questions or comments about this advisory:
- Open an issue in Jira XWiki.org
- Email us at Security Mailing List
Affected versions
Maven
| Package | Vulnerable | Fixed in |
|---|---|---|
| org.xwiki.platform:xwiki-platform | >= 15.0-rc-1, < 15.5.3 |
15.5.3 |
| org.xwiki.platform:xwiki-platform | >= 15.6-rc-1, < 15.8-rc-1 |
15.8-rc-1 |
| org.xwiki.platform:xwiki-platform-oldcore | >= 1.0, < 14.10.17 |
14.10.17 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
org.xwiki.platform:xwiki-platform Maven → 15.5.3
- maven
<dependency><groupId>org.xwiki.platform</groupId><artifactId>xwiki-platform</artifactId><version>15.5.3</version></dependency>- gradle
implementation("org.xwiki.platform:xwiki-platform:15.5.3")
org.xwiki.platform:xwiki-platform-oldcore Maven → 14.10.17
- maven
<dependency><groupId>org.xwiki.platform</groupId><artifactId>xwiki-platform-oldcore</artifactId><version>14.10.17</version></dependency>- gradle
implementation("org.xwiki.platform:xwiki-platform-oldcore:14.10.17")
Severity breakdown
CVSS 3.1 8.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- Required
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Weakness
CWE-274: Improper Handling of Insufficient Privileges
The product does not handle or incorrectly handles when it has insufficient privileges to perform an operation, leading to resultant weaknesses.
References
Advisories
Packages
Other links
- github.com/xwiki/xwiki-platform/security/advisories/GHSA-xh35-w7wg-95v3
- github.com/xwiki/xwiki-platform/commit/1f3220f14bb3a4dcbd10d31134c39a06037f9a74
- github.com/xwiki/xwiki-platform/commit/4de72875ca49602796165412741033bfdbf1e680
- github.com/xwiki/xwiki-platform/commit/4fa7f302b14da6f05a6904a14e3741c4c06c40a1
- jira.xwiki.org/browse/XWIKI-21257
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-qj4x-9g63-25g6 XWiki Platform Old Core: Resource path traversal via /skin/ action endpoint in Jetty 12+ | High | Also affects org.xwiki.platform:xwiki-platform-oldcore |
| GHSA-mrqg-xmgm-rc5g XWiki's REST APIs can list all pages/spaces, leading to unavailability | High | Also affects org.xwiki.platform:xwiki-platform-oldcore |
| GHSA-h259-74h5-4rh9 XWiki vulnerable to remote code execution with script right through unprotected Velocity scripting API | Critical | Also affects org.xwiki.platform:xwiki-platform-oldcore |
| GHSA-57q2-6cp4-9mq3 XWiki exposes passwords and emails stored in fields not named password/email in xml.vm | Medium | Also affects org.xwiki.platform:xwiki-platform-oldcore |
| GHSA-r38m-cgpg-qj69 XWiki leaks password hashes and other accessible password properties | Medium | Also affects org.xwiki.platform:xwiki-platform-oldcore |
| GHSA-p9qm-p942-q3w5 XWiki Platform vulnerable to SQL injection through XWiki#searchDocuments API | Critical | Also affects org.xwiki.platform:xwiki-platform-oldcore |
| GHSA-jp4x-w9cj-97q7 XWiki allows remote code execution through preview of XClass changes in AWM editor | High | Also affects org.xwiki.platform:xwiki-platform-oldcore |
| GHSA-prwh-7838-xf82 XWiki allows SQL injection in query endpoint of REST API with Oracle | Critical | Also affects org.xwiki.platform:xwiki-platform-oldcore |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor