Skip to content

GHSA-xf83-q765-xm6m

`CHECK` fail in `TensorListScatter` and `TensorListScatterV2` in eager mode

Low PyPI
Severity
Low
The publisher's own rating, not a CVSS score
Exploit chance (EPSS)
—
No score published
Known exploited
No
Not in CISA's catalog
Weakness
—
Not classified
Fix
Available
3 packages have a fixed version

Description

Impact

Another instance of CVE-2022-35991, where TensorListScatter and TensorListScatterV2 crash via non scalar inputs inelement_shape, was found in eager mode and fixed.

import tensorflow as tf
arg_0=tf.random.uniform(shape=(2, 2, 2), dtype=tf.float16, maxval=None)
arg_1=tf.random.uniform(shape=(2, 2, 2), dtype=tf.int32, maxval=65536)
arg_2=tf.random.uniform(shape=(2, 2, 2), dtype=tf.int32, maxval=65536)
arg_3=''
tf.raw_ops.TensorListScatter(tensor=arg_0, indices=arg_1, 
element_shape=arg_2, name=arg_3)

Patches

We have patched the issue in GitHub commit bf9932fc907aff0e9e8cccf769e8b00d30fd81a1.

The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1, 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range.

For more information

Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Attribution

This vulnerability has been reported by Pattarakrit Rattankul

Affected versions

PyPI

PackageVulnerableFixed in
tensorflow
< 2.8.4
2.8.4
tensorflow
>= 2.9.0, < 2.9.3
2.9.3
tensorflow
>= 2.10.0, < 2.10.1
2.10.1
tensorflow-cpu
< 2.8.4
2.8.4
tensorflow-cpu
>= 2.9.0, < 2.9.3
2.9.3
tensorflow-cpu
>= 2.10.0, < 2.10.1
2.10.1
tensorflow-gpu
< 2.8.4
2.8.4
tensorflow-gpu
>= 2.9.0, < 2.9.3
2.9.3
tensorflow-gpu
>= 2.10.0, < 2.10.1
2.10.1

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

tensorflow PyPI → 2.8.4

pip
pip install --upgrade "tensorflow>=2.8.4"
poetry
poetry add "tensorflow>=2.8.4"
uv
uv add "tensorflow>=2.8.4"

tensorflow-cpu PyPI → 2.8.4

pip
pip install --upgrade "tensorflow-cpu>=2.8.4"
poetry
poetry add "tensorflow-cpu>=2.8.4"
uv
uv add "tensorflow-cpu>=2.8.4"

tensorflow-gpu PyPI → 2.8.4

pip
pip install --upgrade "tensorflow-gpu>=2.8.4"
poetry
poetry add "tensorflow-gpu>=2.8.4"
uv
uv add "tensorflow-gpu>=2.8.4"

References

Timeline

  1. Published
  2. Last updated by the source
AdvisorySeverityWhy it's related
GHSA-gjh7-xx4r-x345
TensorFlow has segfault in array_ops.upper_bound
High Also affects tensorflow
GHSA-fxgc-95xx-grvq
TensorFlow Denial of Service vulnerability
Medium Also affects tensorflow
GHSA-93vr-9q9m-pj8p
TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch
High Also affects tensorflow
GHSA-qjqc-vqcf-5qvj
TensorFlow vulnerable to seg fault in `tf.raw_ops.Print`
High Also affects tensorflow
GHSA-7jvm-xxmr-v5cw
TensorFlow vulnerable to integer overflow in EditDistance
High Also affects tensorflow
GHSA-64jg-wjww-7c5w
TensorFlow has Null Pointer Error in TensorArrayConcatV2
High Also affects tensorflow
GHSA-6hg6-5c2q-7rcr
TensorFlow has Heap-buffer-overflow in AvgPoolGrad
High Also affects tensorflow
GHSA-558h-mq8x-7q9g
TensorFlow has Null Pointer Error in SparseSparseMaximum
High Also affects tensorflow
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor