Skip to content

GHSA-xcf7-rvmh-g6q4 CVE-2023-53159 RUSTSEC-2023-0044

`openssl` `X509VerifyParamRef::set_host` buffer over-read

Low crates.io
Severity
4.5 / 10
Low · CVSS 3.1
Exploit chance (EPSS)
0.23%
Chance of exploitation in the next 30 days. Higher than 13.31% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-126 Buffer Over-read
Fix
0.10.55
Upgrade openssl to this version or later

Description

When this function was passed an empty string, openssl would attempt to call strlen on it, reading arbitrary memory until it reached a NUL byte.

Affected versions

crates.io

PackageVulnerableFixed in
openssl
>= 0.10.0, < 0.10.55
0.10.55
openssl
>= 0.0.0-0, < 0.10.55
0.10.55

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

openssl crates.io → 0.10.55

cargo
cargo update -p openssl --precise 0.10.55

Severity breakdown

CVSS 3.1 4.5

CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:L/I:N/A:L

Attack vector
Local
Attack complexity
High
Privileges required
None
User interaction
None
Scope
Changed
Confidentiality
Low
Integrity
None
Availability
Low

Weakness

CWE-126: Buffer Over-read

The product reads from a buffer using buffer access mechanisms such as indexes or pointers that reference memory locations after the targeted buffer.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-phqj-4mhp-q6mq
rust-openssl: Potential out-of-bounds write in `CipherCtxRef::cipher_update_inplace` for AES-KW-PAD ciphers
High Also affects openssl
GHSA-xv59-967r-8726
rust-openssl vulnerable to heap buffer overflow when encrypting with AES key-wrap-with-padding
Medium Also affects openssl
GHSA-xp3w-r5p5-63rr
rust-openssl has undefined behavior in X509Ref::ocsp_responders for certificates with non-UTF-8 OCSP URLs
High Also affects openssl
GHSA-pqf5-4pqq-29f5
rust-openssl: Deriver::derive and PkeyCtxRef::derive can overflow short buffers on OpenSSL 1.1.1
High Also affects openssl
GHSA-xmgf-hq76-4vx2
rust-opennssl has an Out-of-bounds read in PEM password callback when returning an oversized length
Critical Also affects openssl
GHSA-8c75-8mhr-p7r9
rust-openssl has incorrect bounds assertion in aes key wrap
High Also affects openssl
GHSA-ghm9-cr32-g9qj
rust-openssl: rustMdCtxRef::digest_final() writes past caller buffer with no length check
High Also affects openssl
GHSA-hppc-g8h3-xhp3
rust-openssl: Unchecked callback length in PSK/cookie trampolines leaks adjacent memory to peer
Medium Also affects openssl
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor