Skip to content

GHSA-x7wf-5mjc-6x76 CVE-2020-28735 PYSEC-2020-247 PYSEC-2026-2881 PYSEC-2026-2884 PYSEC-2026-2887 PYSEC-2026-737

SSRF attacks via tracebacks in Plone

High PyPI
Severity
0.0 / 10
High · CVSS 4.0
Exploit chance (EPSS)
1.45%
Chance of exploitation in the next 30 days. Higher than 73.43% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-918 Server-Side Request Forgery (SSRF)
Fix
Available
5 packages have a fixed version

Description

Plone before 5.2.3 allows SSRF attacks via the tracebacks feature (only available to the Manager role).

Affected versions

PyPI

PackageVulnerableFixed in
plone
< 5.2.3
5.2.3
plone-app-dexterity
< 2.6.8
2.6.8
plone-app-event
< 3.2.10
3.2.10
plone-app-theming
< 4.1.6
4.1.6
plone-supermodel
< 1.6.3
1.6.3

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

plone PyPI → 5.2.3

pip
pip install --upgrade "plone>=5.2.3"
poetry
poetry add "plone>=5.2.3"
uv
uv add "plone>=5.2.3"

plone-app-dexterity PyPI → 2.6.8

pip
pip install --upgrade "plone-app-dexterity>=2.6.8"
poetry
poetry add "plone-app-dexterity>=2.6.8"
uv
uv add "plone-app-dexterity>=2.6.8"

plone-app-event PyPI → 3.2.10

pip
pip install --upgrade "plone-app-event>=3.2.10"
poetry
poetry add "plone-app-event>=3.2.10"
uv
uv add "plone-app-event>=3.2.10"

plone-app-theming PyPI → 4.1.6

pip
pip install --upgrade "plone-app-theming>=4.1.6"
poetry
poetry add "plone-app-theming>=4.1.6"
uv
uv add "plone-app-theming>=4.1.6"

plone-supermodel PyPI → 1.6.3

pip
pip install --upgrade "plone-supermodel>=1.6.3"
poetry
poetry add "plone-supermodel>=1.6.3"
uv
uv add "plone-supermodel>=1.6.3"

Severity breakdown

CVSS 4.0 0.0

CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Attack vector
Network
Attack complexity
Low
Attack requirements
None
Privileges required
Low
User interaction
None
Confidentiality (vulnerable system)
High
Integrity (vulnerable system)
High
Availability (vulnerable system)
High
Confidentiality (subsequent systems)
None
Integrity (subsequent systems)
None
Availability (subsequent systems)
None

CVSS 3.1 8.8

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Attack vector
Network
Attack complexity
Low
Privileges required
Low
User interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
High
Availability
High

Weakness

CWE-918: Server-Side Request Forgery (SSRF)

The web server receives a URL or similar request from an upstream component and retrieves the contents of this URL, but it does not sufficiently ensure that the request is being sent to the expected destination.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-xg5p-8wg5-rhxm
Phone information disclosure vulnerability
High Also affects plone
GHSA-5xfx-55x4-j223
Cross-Frame Scripting vulnerability has been found on Plone CMS
High Also affects plone
GHSA-47p5-p3jw-w78w
Server-Side Request Forgery in Plone CMS
High Also affects plone
GHSA-cvwc-g7fw-7xrj
Plone XSS Vulnerability
Medium Also affects plone
GHSA-pwgm-jvqv-6v8p
Plone anonymous access to sub-objects in CMFEditions where KwAsAttributes classes were publishable
High Also affects plone
GHSA-46f9-f8jm-mw2x
Plone Cross-site Scripting vulnerability in the LiveSearch module
Medium Also affects plone
GHSA-hjp5-hv33-q58g
Plone credentials stored in session cookie
Medium Also affects plone
GHSA-593c-j348-f3gv
Plone Improper Session Management
High Also affects plone
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor