GHSA-wxcc-2f3q-4h58 BIT-grafana-2024-11741 CVE-2024-11741 GO-2025-3438
Grafana Alerting VictorOps integration could be exposed to users with Viewer permission
- Severity
- 4.3 / 10
- Medium · CVSS 3.1
- Exploit chance (EPSS)
- 0.41%
- Chance of exploitation in the next 30 days. Higher than 35.32% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor
- Fix
11.4.1- Upgrade github.com/grafana/grafana to this version or later
Description
Grafana is an open-source platform for monitoring and observability. The Grafana Alerting VictorOps integration was not properly protected and could be exposed to users with Viewer permission. Fixed in versions 11.5.0, 11.4.1, 11.3.3, 11.2.6, 11.1.11, 11.0.11 and 10.4.15
Affected versions
Go
| Package | Vulnerable | Fixed in |
|---|---|---|
| github.com/grafana/grafana | >= 11.4.0, < 11.4.1 |
11.4.1 |
| github.com/grafana/grafana | >= 11.3.0, < 11.3.3 |
11.3.3 |
| github.com/grafana/grafana | >= 11.2.0, < 11.2.6 |
11.2.6 |
| github.com/grafana/grafana | >= 11.1.0, < 11.1.11 |
11.1.11 |
| github.com/grafana/grafana | >= 11.0.0, < 11.0.11 |
11.0.11 |
| github.com/grafana/grafana | >= 1.9.2, < 10.4.15 |
10.4.15 |
| github.com/grafana/grafana | < 0.0.0-20250129224826-70073427041e |
0.0.0-20250129224826-70073427041e |
| github.com/grafana/grafana | >= 0.0.0, < 1.9.2-0.20250129224826-70073427041e |
1.9.2-0.20250129224826-70073427041e |
| github.com/grafana/grafana | all versions |
No fix yet |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
github.com/grafana/grafana Go → 11.4.1
- go
go get github.com/grafana/grafana@v11.4.1 && go mod tidy
Severity breakdown
CVSS 3.1 4.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Weakness
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information.
How to prevent it
- Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.
References
Advisories
Packages
Other links
- github.com/grafana/grafana/commit/70073427041e15c353e0d467b714527584765aea
- grafana.com/security/security-advisories/cve-2024-11741
- pkg.go.dev/vuln/GO-2025-3438
- security.netapp.com/advisory/ntap-20250509-0006
- grafana.com/security/security-advisories/cve-2024-11741
- security.netapp.com/advisory/ntap-20250509-0006
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-8pjx-jj86-j47p Grafana path traversal | High Known exploited | Also affects github.com/grafana/grafana |
| CVE-2021-39226 Authentication bypass for viewing and deletions of snapshots | High Known exploited | Also affects github.com/grafana/grafana |
| GHSA-3w66-95m3-8jxg Grafana: Pre-authentication denial of service in the public dashboard query handler | High | Also affects github.com/grafana/grafana |
| GHSA-9g84-39mm-q4p3 Grafana geomap panel's XYZ tile layer has a sanitize-then-interpolate ordering bug | Medium | Also affects github.com/grafana/grafana |
| GHSA-f74p-cwhp-x2wx Grafana Loki datasource plugin's callResource handler contains a path traversal vulnerability. | High | Also affects github.com/grafana/grafana |
| GHSA-9493-h4f5-633x Grafana: Path traversal in the Tempo and Loki data source plugins | Medium | Also affects github.com/grafana/grafana |
| GHSA-wfhv-mj62-f5xh Grafana: Users can generate Service Account tokens after permissions removal | High | Also affects github.com/grafana/grafana |
| GHSA-gxcp-jjxh-rwp4 Grafana: SQL Expressions Read File From Disk | Medium | Also affects github.com/grafana/grafana |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor