Skip to content

GHSA-wwjw-r3gj-39fq BIT-typo3-2022-31050 CVE-2022-31050

Insufficient Session Expiration in TYPO3's Admin Tool

Medium Packagist
Severity
6.0 / 10
Medium · CVSS 3.1
Exploit chance (EPSS)
1.26%
Chance of exploitation in the next 30 days. Higher than 69.50% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-613 Insufficient Session Expiration
Fix
Available
2 packages have a fixed version

Description

Meta

  • CVSS: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:L/E:F/RL:O/RC:C (5.6)

Problem

Admin Tool sessions initiated via the TYPO3 backend user interface have not been revoked even if the corresponding user account was degraded to lower permissions or disabled completely. This way, sessions in the admin tool theoretically could have been prolonged without any limit.

Solution

Update to TYPO3 versions 9.5.35 ELTS, 10.4.29, 11.5.11 that fix the problem described above.

Credits

Thanks to Kien Hoang who reported this issue and to TYPO3 framework merger Ralf Zimmermann and TYPO3 security member Oliver Hader who fixed the issue.

References

Affected versions

Packagist

PackageVulnerableFixed in
typo3/cms
>= 10.0.0, < 10.4.29
10.4.29
typo3/cms
>= 11.0.0, < 11.5.11
11.5.11
typo3/cms-core
>= 9.0.0, < 9.5.35
9.5.35
typo3/cms-core
>= 10.0.0, < 10.4.29
10.4.29
typo3/cms-core
>= 11.0.0, < 11.5.11
11.5.11

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

typo3/cms Packagist → 10.4.29

composer
composer require typo3/cms:^10.4.29

typo3/cms-core Packagist → 9.5.35

composer
composer require typo3/cms-core:^9.5.35

Severity breakdown

CVSS 3.1 6.0

CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:L

Attack vector
Network
Attack complexity
Low
Privileges required
High
User interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
Low
Availability
Low

Weakness

CWE-613: Insufficient Session Expiration

According to WASC, "Insufficient Session Expiration is when a web site permits an attacker to reuse old session credentials or session IDs for authorization."

How to prevent it
  • Implementation: Set sessions/credentials expiration date.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-68jx-f42c-7599
TYPO3 CMS - Broken Access Control in Backend and Install Tool
High Also affects typo3/cms-core
GHSA-chm7-4vch-h8vr
TYPO3 CMS has Broken Access Control in its Media Module
High Also affects typo3/cms-core
GHSA-jh32-v29g-68pq
TYPO3 CMS has Privilege Escalation & SQL Injection in its Form Framework
High Also affects typo3/cms-core
GHSA-c78m-c52x-jgwp
TYPO3 CMS has Insecure Deserialization via Core API
Medium Also affects typo3/cms-core
GHSA-jf56-v8jc-jcc5
TYPO3 CMS has Broken Access Control in its File Abstraction Layer
Low Also affects typo3/cms-core
GHSA-2j54-93q2-3hjq
TYPO3 CMS has Broken Access Control in Backend API
Medium Also affects typo3/cms-core
GHSA-q93m-25xv-94hh
TYPO3 CMS: Broken Access Control in Media Module
Medium Also affects typo3/cms-core
GHSA-qcmw-6rm2-5x78
TYPO3 CMS has Broken Access Control in its DataHandler
Medium Also affects typo3/cms-core
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor