Skip to content

GHSA-wqq5-c89p-3wc3 CVE-2014-4966 PYSEC-2020-204

Ansible Arbitrary Code Execution

Critical PyPI
Severity
0.0 / 10
Critical · CVSS 4.0
Exploit chance (EPSS)
3.55%
Chance of exploitation in the next 30 days. Higher than 89.31% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')
Fix
1.6.7
Upgrade ansible to this version or later

Description

Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings, and does not prevent remote data with "{{" substrings, which allows remote attackers to execute arbitrary code via (1) crafted lookup('pipe') calls or (2) crafted Jinja2 data.

Affected versions

PyPI

PackageVulnerableFixed in
ansible
< 1.6.7
1.6.7
ansible
< 1.6.7
1.6.7

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

ansible PyPI → 1.6.7

pip
pip install --upgrade "ansible>=1.6.7"
poetry
poetry add "ansible>=1.6.7"
uv
uv add "ansible>=1.6.7"

Severity breakdown

CVSS 4.0 0.0

CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Attack vector
Network
Attack complexity
Low
Attack requirements
None
Privileges required
None
User interaction
None
Confidentiality (vulnerable system)
High
Integrity (vulnerable system)
High
Availability (vulnerable system)
High
Confidentiality (subsequent systems)
None
Integrity (subsequent systems)
None
Availability (subsequent systems)
None

CVSS 3.1 9.8

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
High
Availability
High

Weakness

CWE-74: Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')

The product constructs all or part of a command, data structure, or record using externally-influenced input from an upstream component, but it does not neutralize or incorrectly neutralizes special elements that could modify how it is parsed or interpreted when it is sent to a downstream component.

How to prevent it
  • Requirements: Programming languages and supporting technologies might be chosen which are not subject to these issues.
  • Implementation: Utilize an appropriate mix of allowlist and denylist parsing to filter control-plane syntax from all input.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-8ggh-xwr9-3373
Ansible Community General Collection is vulnerable to exposure of sensitive information
Medium Also affects ansible
GHSA-jpvw-p8pr-9g2x
Ansible symlink attack vulnerability
Medium Also affects ansible
GHSA-cpx3-93w7-457x
Ansible leaks password to logs
High Also affects ansible
GHSA-fh5v-5f35-2rv2
Insertion of Sensitive Information into Log File in ansible
Medium Also affects ansible
GHSA-4r65-35qq-ch8j
Ansible discloses sensitive information in traceback error message
Medium Also affects ansible
GHSA-2pfh-q76x-gwvm
Improper Input Validation and Command Injection in Ansible
High Also affects ansible
PYSEC-2021-126
A flaw was found in Ansible if an ansible user sets ANSIBLE_ASYNC_DIR to a subdirectory of a world writable directory.
Not rated yet Also affects ansible
GHSA-r6h7-5pq2-j77h
Insufficiently random values in Ansible
Medium Also affects ansible
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor