GHSA-w4xf-2pqw-5mq7 BIT-tensorflow-2021-37666 CVE-2021-37666 PYSEC-2021-288 PYSEC-2021-579 PYSEC-2021-777
Reference binding to nullptr in `RaggedTensorToVariant`
- Severity
- 0.0 / 10
- High · CVSS 4.0
- Exploit chance (EPSS)
- 0.17%
- Chance of exploitation in the next 30 days. Higher than 6.79% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-824 Access of Uninitialized Pointer
- Fix
- Available
- 3 packages have a fixed version
Description
Impact
An attacker can cause undefined behavior via binding a reference to null pointer in tf.raw_ops.RaggedTensorToVariant:
import tensorflow as tf
tf.raw_ops.RaggedTensorToVariant(
rt_nested_splits=[],
rt_dense_values=[1,2,3],
batched_input=True)
The implementation has an incomplete validation of the splits values, missing the case when the argument would be empty.
Patches
We have patched the issue in GitHub commit be7a4de6adfbd303ce08be4332554dff70362612.
The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by members of the Aivul Team from Qihoo 360.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| tensorflow | < 2.3.4 |
2.3.4 |
| tensorflow | >= 2.4.0, < 2.4.3 |
2.4.3 |
| tensorflow | >= 2.5.0, < 2.5.1 |
2.5.1 |
| tensorflow | >= 2.3.0, < 2.3.4>= 2.4.0, < 2.4.3 |
2.3.42.4.3 |
| tensorflow-cpu | < 2.3.4 |
2.3.4 |
| tensorflow-cpu | >= 2.4.0, < 2.4.3 |
2.4.3 |
| tensorflow-cpu | >= 2.5.0, < 2.5.1 |
2.5.1 |
| tensorflow-cpu | >= 2.3.0, < 2.3.4>= 2.4.0, < 2.4.3 |
2.3.42.4.3 |
| tensorflow-gpu | < 2.3.4 |
2.3.4 |
| tensorflow-gpu | >= 2.4.0, < 2.4.3 |
2.4.3 |
| tensorflow-gpu | >= 2.5.0, < 2.5.1 |
2.5.1 |
| tensorflow-gpu | >= 2.3.0, < 2.3.4>= 2.4.0, < 2.4.3 |
2.3.42.4.3 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
tensorflow PyPI → 2.3.4
- pip
pip install --upgrade "tensorflow>=2.3.4"- poetry
poetry add "tensorflow>=2.3.4"- uv
uv add "tensorflow>=2.3.4"
tensorflow-cpu PyPI → 2.3.4
- pip
pip install --upgrade "tensorflow-cpu>=2.3.4"- poetry
poetry add "tensorflow-cpu>=2.3.4"- uv
uv add "tensorflow-cpu>=2.3.4"
tensorflow-gpu PyPI → 2.3.4
- pip
pip install --upgrade "tensorflow-gpu>=2.3.4"- poetry
poetry add "tensorflow-gpu>=2.3.4"- uv
uv add "tensorflow-gpu>=2.3.4"
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- Attack vector
- Local
- Attack complexity
- Low
- Attack requirements
- None
- Privileges required
- Low
- User interaction
- None
- Confidentiality (vulnerable system)
- High
- Integrity (vulnerable system)
- High
- Availability (vulnerable system)
- High
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.1 7.8
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Attack vector
- Local
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Weakness
CWE-824: Access of Uninitialized Pointer
The product accesses or uses a pointer that has not been initialized.
References
Advisories
Packages
Other links
- github.com/tensorflow/tensorflow/security/advisories/GHSA-w4xf-2pqw-5mq7
- github.com/tensorflow/tensorflow/commit/be7a4de6adfbd303ce08be4332554dff70362612
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-579…
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-777…
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-288.yaml
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gjh7-xx4r-x345 TensorFlow has segfault in array_ops.upper_bound | High | Also affects tensorflow |
| GHSA-fxgc-95xx-grvq TensorFlow Denial of Service vulnerability | Medium | Also affects tensorflow |
| GHSA-93vr-9q9m-pj8p TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch | High | Also affects tensorflow |
| GHSA-qjqc-vqcf-5qvj TensorFlow vulnerable to seg fault in `tf.raw_ops.Print` | High | Also affects tensorflow |
| GHSA-7jvm-xxmr-v5cw TensorFlow vulnerable to integer overflow in EditDistance | High | Also affects tensorflow |
| GHSA-64jg-wjww-7c5w TensorFlow has Null Pointer Error in TensorArrayConcatV2 | High | Also affects tensorflow |
| GHSA-6hg6-5c2q-7rcr TensorFlow has Heap-buffer-overflow in AvgPoolGrad | High | Also affects tensorflow |
| GHSA-558h-mq8x-7q9g TensorFlow has Null Pointer Error in SparseSparseMaximum | High | Also affects tensorflow |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor