Skip to content

GHSA-w2hr-3mc8-46gh CVE-2021-3144 PYSEC-2021-54

SaltStack Salt eauth tokens can be used once after expiration

Critical PyPI
Severity
9.1 / 10
Critical · CVSS 3.1
Exploit chance (EPSS)
5.10%
Chance of exploitation in the next 30 days. Higher than 92.37% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-613 Insufficient Session Expiration
Fix
2015.8.13
Upgrade salt to this version or later

Description

In SaltStack Salt before 3002.5, eauth tokens can be used once after expiration. (They might be used to run command against the salt master or minions.)

Affected versions

PyPI

PackageVulnerableFixed in
salt
< 2015.8.13
2015.8.13
salt
>= 2016.3.0, < 2016.11.5
2016.11.5
salt
>= 2016.11.7, < 2016.11.10
2016.11.10
salt
>= 2017.5.0, < 2017.7.8
2017.7.8
salt
>= 2018.2.0, <= 2018.3.5
No fix yet
salt
>= 3000, < 3000.7
3000.7
salt
>= 3001, < 3001.5
3001.5
salt
>= 3002, < 3002.3
3002.3
salt
>= 2019.2.0, < 2019.2.8
2019.2.8
salt
< 2015.8.10
>= 2015.8.11, < 2015.8.13
>= 2016.3.0, < 2016.3.4
>= 2016.3.5, < 2016.3.6
>= 2016.3.7, < 2016.3.8
>= 2016.11.0, < 2016.11.3
>= 2016.11.4, < 2016.11.5
>= 2016.11.7, < 2016.11.10
>= 2017.7.0, < 2017.7.8
>= 2018.3.0rc1, < 2019.2.0rc1
>= 2019.2.0, < 2019.2.5
>= 2019.2.6, < 2019.2.8
>= 3000, < 3000.6
>= 3001, < 3001.4
>= 3002, < 3002.5
2015.8.10
2015.8.13
2016.3.4
2016.3.6
2016.3.8
2016.11.3
2016.11.5
2016.11.10
2017.7.8
2019.2.0rc1
2019.2.5
2019.2.8
3000.6
3001.4
3002.5

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

salt PyPI → 2015.8.13

pip
pip install --upgrade "salt>=2015.8.13"
poetry
poetry add "salt>=2015.8.13"
uv
uv add "salt>=2015.8.13"

Severity breakdown

CVSS 3.1 9.1

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
High
Availability
None

Weakness

CWE-613: Insufficient Session Expiration

According to WASC, "Insufficient Session Expiration is when a web site permits an attacker to reuse old session credentials or session IDs for authorization."

How to prevent it
  • Implementation: Set sessions/credentials expiration date.

References

Advisories

Packages

Other links

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
CVE-2020-16846
SaltStack Salt Command Injection in netapi ssh client
Critical Known exploited Also affects salt
CVE-2020-11652
SaltStack Salt is vulnerable Arbitrary Directory Access
High Known exploited Also affects salt
CVE-2020-11651
SaltStack Salt Unauthenticated Remote Code Execution
Critical Known exploited Also affects salt
GHSA-vcf3-26xf-fw4m
Salt Authentication Protocol Version Downgrade Allows Minion Impersonation
Medium Also affects salt
GHSA-77w2-v593-vxvv
Salt junos Module Vulnerable to Code Injection via Specially Crafted YAML Payload
High Also affects salt
GHSA-8pcp-r83j-fc92
Salt vulnerable to directory traversal attack in file receiving method
High Also affects salt
GHSA-989c-m532-p2hv
Salt's worker process vulnerable to denial of service through file read operation
Medium Also affects salt
GHSA-7f3f-x5f5-79gw
Salt's file contents overwrite the VirtKey class
Medium Also affects salt
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor