Skip to content

GHSA-vwhq-49r4-gj9v BIT-tensorflow-2021-41214 CVE-2021-41214 PYSEC-2021-406 PYSEC-2021-623 PYSEC-2021-821

Reference binding to `nullptr` in `tf.ragged.cross`

High PyPI
Severity
7.8 / 10
High · CVSS 3.1
Exploit chance (EPSS)
0.22%
Chance of exploitation in the next 30 days. Higher than 12.16% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-824 Access of Uninitialized Pointer
Fix
Available
3 packages have a fixed version

Description

Impact

The shape inference code for tf.ragged.cross has an undefined behavior due to binding a reference to nullptr. In the following scenario, this results in a crash:

import tensorflow as tf
  
@tf.function                 
def test():     
  y = tf.ragged.cross([tf.ragged.constant([['1']]),'2'])
  return y                   
                             
test()        

Patches

We have patched the issue in GitHub commit fa6b7782fbb14aa08d767bc799c531f5e1fb3bb8.

The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.

For more information

Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Attribution

This vulnerability has been reported by members of the Aivul Team from Qihoo 360.

Affected versions

PyPI

PackageVulnerableFixed in
tensorflow
>= 2.6.0, < 2.6.1
2.6.1
tensorflow
>= 2.5.0, < 2.5.2
2.5.2
tensorflow
< 2.4.4
2.4.4
tensorflow
< 2.4.4
>= 2.5.0, < 2.5.2
>= 2.6.0, < 2.6.1
>= 2.7.0rc0, < 2.7.0
2.4.4
2.5.2
2.6.1
2.7.0
tensorflow-cpu
>= 2.6.0, < 2.6.1
2.6.1
tensorflow-cpu
>= 2.5.0, < 2.5.2
2.5.2
tensorflow-cpu
< 2.4.4
2.4.4
tensorflow-cpu
< 2.4.4
>= 2.5.0, < 2.5.2
>= 2.6.0, < 2.6.1
>= 2.7.0rc0, < 2.7.0
2.4.4
2.5.2
2.6.1
2.7.0
tensorflow-gpu
>= 2.6.0, < 2.6.1
2.6.1
tensorflow-gpu
>= 2.5.0, < 2.5.2
2.5.2
tensorflow-gpu
< 2.4.4
2.4.4
tensorflow-gpu
< 2.4.4
>= 2.5.0, < 2.5.2
>= 2.6.0, < 2.6.1
>= 2.7.0rc0, < 2.7.0
2.4.4
2.5.2
2.6.1
2.7.0

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

tensorflow PyPI → 2.6.1

pip
pip install --upgrade "tensorflow>=2.6.1"
poetry
poetry add "tensorflow>=2.6.1"
uv
uv add "tensorflow>=2.6.1"

tensorflow-cpu PyPI → 2.6.1

pip
pip install --upgrade "tensorflow-cpu>=2.6.1"
poetry
poetry add "tensorflow-cpu>=2.6.1"
uv
uv add "tensorflow-cpu>=2.6.1"

tensorflow-gpu PyPI → 2.6.1

pip
pip install --upgrade "tensorflow-gpu>=2.6.1"
poetry
poetry add "tensorflow-gpu>=2.6.1"
uv
uv add "tensorflow-gpu>=2.6.1"

Severity breakdown

CVSS 3.1 7.8

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Attack vector
Local
Attack complexity
Low
Privileges required
Low
User interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
High
Availability
High

Weakness

CWE-824: Access of Uninitialized Pointer

The product accesses or uses a pointer that has not been initialized.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-gjh7-xx4r-x345
TensorFlow has segfault in array_ops.upper_bound
High Also affects tensorflow
GHSA-fxgc-95xx-grvq
TensorFlow Denial of Service vulnerability
Medium Also affects tensorflow
GHSA-93vr-9q9m-pj8p
TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch
High Also affects tensorflow
GHSA-qjqc-vqcf-5qvj
TensorFlow vulnerable to seg fault in `tf.raw_ops.Print`
High Also affects tensorflow
GHSA-7jvm-xxmr-v5cw
TensorFlow vulnerable to integer overflow in EditDistance
High Also affects tensorflow
GHSA-64jg-wjww-7c5w
TensorFlow has Null Pointer Error in TensorArrayConcatV2
High Also affects tensorflow
GHSA-6hg6-5c2q-7rcr
TensorFlow has Heap-buffer-overflow in AvgPoolGrad
High Also affects tensorflow
GHSA-558h-mq8x-7q9g
TensorFlow has Null Pointer Error in SparseSparseMaximum
High Also affects tensorflow
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor