Skip to content

GHSA-vv65-fjfj-4736 BIT-superset-2023-42501 CVE-2023-42501 PYSEC-2026-1188

Apache Superset has Incorrect Default Permissions

Medium PyPI
Severity
4.3 / 10
Medium · CVSS 3.1
Exploit chance (EPSS)
0.86%
Chance of exploitation in the next 30 days. Higher than 58.51% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-276 Incorrect Default Permissions
Fix
2.1.2
Upgrade apache-superset to this version or later

Description

Unnecessary read permissions within the Gamma role would allow authenticated users to read configured CSS templates and annotations. This issue affects Apache Superset: before 2.1.2. Users should upgrade to version or above 2.1.2 and run superset init to reconstruct the Gamma role or remove can_read permission from the mentioned resources.

Affected versions

PyPI

PackageVulnerableFixed in
apache-superset
< 2.1.2
2.1.2

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

apache-superset PyPI → 2.1.2

pip
pip install --upgrade "apache-superset>=2.1.2"
poetry
poetry add "apache-superset>=2.1.2"
uv
uv add "apache-superset>=2.1.2"

Severity breakdown

CVSS 3.1 4.3

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Attack vector
Network
Attack complexity
Low
Privileges required
Low
User interaction
None
Scope
Unchanged
Confidentiality
Low
Integrity
None
Availability
None

Weakness

CWE-276: Incorrect Default Permissions

During installation, installed file permissions are set to allow anyone to modify those files.

How to prevent it
  • Architecture and Design, Operation: The architecture needs to access and modification attributes for files to only those users who actually require those actions.
  • Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-5cx2-vq3h-x52c
Apache superset missing check for default SECRET_KEY
Critical Known exploited Also affects apache-superset
GHSA-mwf2-qr4v-94h2
Apache Superset: Read-Only Bypass via Improper Input Validation on PostgreSQL Connections
Medium Also affects apache-superset
GHSA-h294-8fxm-m2pj
Apache Superset allows authenticated users to view sensitive data without explicit permissions
Medium Also affects apache-superset
GHSA-3m2g-v7jf-7fxc
Apache Superset Improper Authorization allows low-privileged users to bypass access controls
Medium Also affects apache-superset
GHSA-gvxg-9hqx-f4rg
Apache Superset allows privileged users to conduct error-based SQL Injection
Medium Also affects apache-superset
GHSA-48m2-v2r8-h23m
Apache Superset: Incomplete DISALLOWED_SQL_FUNCTIONS default list for ClickHouse engine
Medium Also affects apache-superset
GHSA-mhpq-m962-mg92
Apache Superset allows authenticated users to discover metadata about datasources they don't have permission to access
Medium Also affects apache-superset
GHSA-fxgf-3xh6-m2pp
Apache Superset has bypass of `DISALLOWED_SQL_FUNCTIONS` that allows execution of blocked SQL functions
Medium Also affects apache-superset
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor