GHSA-vfxj-qg93-7wwc CVE-2018-10189
Mautic Sessions could be hijacked due to tracking contacts by an auto-incremented ID
- Severity
- 7.5 / 10
- High · CVSS 3.0
- Exploit chance (EPSS)
- 1.14%
- Chance of exploitation in the next 30 days. Higher than 66.55% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor
- Fix
2.13.0- Upgrade mautic/core to this version or later
Description
Impact
An issue was discovered in Mautic 1.x and 2.x before 2.13.0. It is possible to systematically emulate tracking cookies per contact due to tracking the contact by their auto-incremented ID. Thus, a third party can manipulate the cookie value with +1 to systematically assume being tracked as each contact in Mautic. It is then possible to retrieve information about the contact through forms that have progressive profiling enabled.
Patches
Update to 2.13.0 or later
Workarounds
None
For more information
If you have any questions or comments about this advisory:
- Email us at security@mautic.org
Affected versions
Packagist
| Package | Vulnerable | Fixed in |
|---|---|---|
| mautic/core | < 2.13.0 |
2.13.0 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
mautic/core Packagist → 2.13.0
- composer
composer require mautic/core:^2.13.0
Severity breakdown
CVSS 3.0 7.5
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Weakness
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information.
How to prevent it
- Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.
References
Advisories
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-5hvg-w58j-545m Mautic has Stored Cross-Site Scripting (XSS) in Project Option Selector | Medium | Also affects mautic/core |
| GHSA-7h65-whp7-rgqf Mautic has Stored Cross-Site Scripting (XSS) in Projects Component | High | Also affects mautic/core |
| GHSA-2jrw-c95w-h43g Mautic has an Authorization Bypass in API v2 Endpoints | High | Also affects mautic/core |
| GHSA-6r9h-4h75-7q4x Mautic vulnerable to Path Traversal via Campaign Import | Critical | Also affects mautic/core |
| GHSA-9fx4-7cmj-47vg Mautic has Server-Side Template Injection (SSTI) in Theme Templates | Critical | Also affects mautic/core |
| GHSA-jmv8-8j9j-rcpc Mautic Focus component Vulnerable to SSRF | Medium | Also affects mautic/core |
| GHSA-fcmw-wx57-9p75 Mautic has SQL Injection in API Contact Filtering | High | Also affects mautic/core |
| GHSA-r5j5-q42h-fc93 Mautic is Vulnerable to SQL Injection through Contact Activity API Sorting | High | Also affects mautic/core |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor