GHSA-v5xg-3q2c-c2r4 BIT-tensorflow-2022-35960 CVE-2022-35960 PYSEC-2026-1036 PYSEC-2026-3243 PYSEC-2026-3370
TensorFlow vulnerable to `CHECK` failure in `TensorListReserve` via missing validation
- Severity
- 5.9 / 10
- Medium · CVSS 3.1
- Exploit chance (EPSS)
- 0.70%
- Chance of exploitation in the next 30 days. Higher than 53.23% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-617 Reachable Assertion
- Fix
- Available
- 3 packages have a fixed version
Description
Impact
In core/kernels/list_kernels.cc's TensorListReserve, num_elements is assumed to be a tensor of size 1. When a num_elements of more than 1 element is provided, then tf.raw_ops.TensorListReserve fails the CHECK_EQ in CheckIsAlignedAndSingleElement.
import tensorflow as tf
tf.raw_ops.TensorListReserve(element_shape=(1,1), num_elements=tf.constant([1,1], dtype=tf.int32), element_dtype=tf.int8)
Patches
We have patched the issue in GitHub commit b5f6fbfba76576202b72119897561e3bd4f179c7.
The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by Kang Hong Jin from Singapore Management University.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| tensorflow | < 2.7.2 |
2.7.2 |
| tensorflow | >= 2.8.0, < 2.8.1 |
2.8.1 |
| tensorflow | >= 2.9.0, < 2.9.1 |
2.9.1 |
| tensorflow | < 2.7.2>= 2.8.0, < 2.8.1>= 2.9.0, < 2.9.1 |
2.7.22.8.12.9.1 |
| tensorflow-cpu | < 2.7.2 |
2.7.2 |
| tensorflow-cpu | >= 2.8.0, < 2.8.1 |
2.8.1 |
| tensorflow-cpu | >= 2.9.0, < 2.9.1 |
2.9.1 |
| tensorflow-cpu | < 2.7.2>= 2.8.0, < 2.8.1>= 2.9.0, < 2.9.1 |
2.7.22.8.12.9.1 |
| tensorflow-gpu | < 2.7.2 |
2.7.2 |
| tensorflow-gpu | >= 2.8.0, < 2.8.1 |
2.8.1 |
| tensorflow-gpu | >= 2.9.0, < 2.9.1 |
2.9.1 |
| tensorflow-gpu | < 2.7.2>= 2.8.0, < 2.8.1>= 2.9.0, < 2.9.1 |
2.7.22.8.12.9.1 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
tensorflow PyPI → 2.7.2
- pip
pip install --upgrade "tensorflow>=2.7.2"- poetry
poetry add "tensorflow>=2.7.2"- uv
uv add "tensorflow>=2.7.2"
tensorflow-cpu PyPI → 2.7.2
- pip
pip install --upgrade "tensorflow-cpu>=2.7.2"- poetry
poetry add "tensorflow-cpu>=2.7.2"- uv
uv add "tensorflow-cpu>=2.7.2"
tensorflow-gpu PyPI → 2.7.2
- pip
pip install --upgrade "tensorflow-gpu>=2.7.2"- poetry
poetry add "tensorflow-gpu>=2.7.2"- uv
uv add "tensorflow-gpu>=2.7.2"
Severity breakdown
CVSS 3.1 5.9
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- Attack vector
- Network
- Attack complexity
- High
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Weakness
CWE-617: Reachable Assertion
The product contains an assert() or similar statement that can be triggered by an attacker, which leads to an application exit or other behavior that is more severe than necessary.
How to prevent it
- Implementation: Make sensitive open/close operation non reachable by directly user-controlled data (e.g. open/close resources)
- Implementation: Perform input validation on user data.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gjh7-xx4r-x345 TensorFlow has segfault in array_ops.upper_bound | High | Also affects tensorflow |
| GHSA-fxgc-95xx-grvq TensorFlow Denial of Service vulnerability | Medium | Also affects tensorflow |
| GHSA-93vr-9q9m-pj8p TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch | High | Also affects tensorflow |
| GHSA-qjqc-vqcf-5qvj TensorFlow vulnerable to seg fault in `tf.raw_ops.Print` | High | Also affects tensorflow |
| GHSA-7jvm-xxmr-v5cw TensorFlow vulnerable to integer overflow in EditDistance | High | Also affects tensorflow |
| GHSA-64jg-wjww-7c5w TensorFlow has Null Pointer Error in TensorArrayConcatV2 | High | Also affects tensorflow |
| GHSA-6hg6-5c2q-7rcr TensorFlow has Heap-buffer-overflow in AvgPoolGrad | High | Also affects tensorflow |
| GHSA-558h-mq8x-7q9g TensorFlow has Null Pointer Error in SparseSparseMaximum | High | Also affects tensorflow |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor