Skip to content

GHSA-rpw8-82v9-3q87 CVE-2025-57766 PYSEC-2026-1348

Fides' Admin UI User Password Change Does Not Invalidate Current Session

Medium PyPI
Severity
0.0 / 10
Medium · CVSS 4.0
Exploit chance (EPSS)
0.30%
Chance of exploitation in the next 30 days. Higher than 22.48% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-613 Insufficient Session Expiration
Fix
2.69.1
Upgrade ethyca-fides to this version or later

Description

Summary

Admin UI user password changes in Fides do not invalidate active user sessions, creating a vulnerability chaining opportunity where attackers who have obtained session tokens through other attack vectors (such as XSS) can maintain access even after password reset. This issue is not directly exploitable on its own and requires a prerequisite vulnerability to obtain valid session tokens in the first place.

Details

Fides uses encrypted authentication tokens with extended expiration periods. When a password is changed via password reset endpoints, the system updates the password hash in the database but does not invalidate existing client sessions or tokens. The authentication system validates tokens based on their cryptographic integrity and expiration time, not against the current password state.

The frontend application stores authentication state in browser local storage, which persists across browser sessions until explicit logout or natural token expiration.

This behavior alone does not constitute a directly exploitable vulnerability. The security issue only becomes exploitable when chained with other vulnerabilities or conditions that allow attackers to obtain valid session tokens, such as:

  • Cross-Site Scripting (XSS) attacks that can access browser storage where tokens are stored
  • Session hijacking through network interception
  • Malware on the user's device that can read browser storage
  • Physical device access where attackers can access browser storage directly

Impact

This vulnerability serves as a persistence mechanism in attack chains rather than a primary attack vector. When chained with token theft vulnerabilities, it allows attackers to:

  • Maintain access beyond the remediation window when users change passwords in response to suspected compromise
  • Extend the impact timeframe of client-side attacks from minutes/hours to potentially an extended period
  • Defeat common incident response procedures that rely on password changes to secure compromised accounts

Stored tokens persist across browser sessions until explicit logout or natural expiration.

Patches

The vulnerability has been patched in Fides version 2.69.1. Users are advised to upgrade to this version or later to secure their systems against this threat.

Workarounds

There are no workarounds.

Severity

This vulnerability has been assigned a severity of LOW because:

  • No direct exploitability - requires chaining with other vulnerabilities
  • High attack complexity - multiple successful exploits needed
  • Limited standalone impact - only extends existing compromises
  • Aligns with industry standard classifications of LOW severity for session invalidation failures

This is fundamentally a defense-in-depth issue rather than a primary security vulnerability.

Affected versions

PyPI

PackageVulnerableFixed in
ethyca-fides
< 2.69.1
2.69.1

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

ethyca-fides PyPI → 2.69.1

pip
pip install --upgrade "ethyca-fides>=2.69.1"
poetry
poetry add "ethyca-fides>=2.69.1"
uv
uv add "ethyca-fides>=2.69.1"

Severity breakdown

CVSS 4.0 0.0

CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:U

Attack vector
Network
Attack complexity
Low
Attack requirements
Present
Privileges required
None
User interaction
None
Confidentiality (vulnerable system)
Low
Integrity (vulnerable system)
Low
Availability (vulnerable system)
None
Confidentiality (subsequent systems)
None
Integrity (subsequent systems)
None
Availability (subsequent systems)
None
Exploit maturity
Unreported

CVSS 3.1 4.8

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Attack vector
Network
Attack complexity
High
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
Low
Integrity
Low
Availability
None

Weakness

CWE-613: Insufficient Session Expiration

According to WASC, "Insufficient Session Expiration is when a web site permits an attacker to reuse old session credentials or session IDs for authorization."

How to prevent it
  • Implementation: Set sessions/credentials expiration date.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-5qrq-9645-g5g2
ethyca-fides has a DOM-based XSS vulnerability in fides.js via fides_description override
High Also affects ethyca-fides
GHSA-qx5f-ghc2-7g5c
Ethyca Fides has a Privacy Request Identity Verification Bypass Vulnerability via Duplicate Detection
Medium Also affects ethyca-fides
GHSA-hjfh-p8f5-24wr
Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation
High Also affects ethyca-fides
GHSA-fq34-xw6c-fphf
Fides Webserver API Rate Limiting Vulnerability in Proxied Environments
High Also affects ethyca-fides
GHSA-7q62-r88r-j5gw
Fides has a Lack of Brute-Force Protections on Authentication Endpoints
Medium Also affects ethyca-fides
GHSA-v7vm-rhmg-8j2r
Password Policy Bypass Vulnerability in Fides Webserver User Accept Invite API
High Also affects ethyca-fides
GHSA-c34r-238x-f7qx
Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine
High Also affects ethyca-fides
GHSA-2h46-8gf5-fmxv
Timing-Based Username Enumeration Vulnerability in Fides Webserver Authentication
Medium Also affects ethyca-fides
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor