GHSA-rh87-q4vg-m45j BIT-tensorflow-2022-36015 CVE-2022-36015 PYSEC-2026-1033 PYSEC-2026-3237 PYSEC-2026-3367
TensorFlow vulnerable to integer overflow in math ops
- Severity
- Low
- The publisher's own rating, not a CVSS score
- Exploit chance (EPSS)
- 0.70%
- Chance of exploitation in the next 30 days. Higher than 53.23% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-190 Integer Overflow or Wraparound
- Fix
- Available
- 3 packages have a fixed version
Description
Impact
When RangeSize receives values that do not fit into an int64_t, it crashes.
auto size = (std::is_integral<T>::value
? ((Eigen::numext::abs(limit - start) +
Eigen::numext::abs(delta) - T(1)) /
Eigen::numext::abs(delta))
: (Eigen::numext::ceil(
Eigen::numext::abs((limit - start) / delta))));
// This check does not cover all cases.
if (size > std::numeric_limits<int64_t>::max()) {
return errors::InvalidArgument("Requires ((limit - start) / delta) <= ",
std::numeric_limits<int64_t>::max());
}
c->set_output(0, c->Vector(static_cast<int64_t>(size)));
return Status::OK();
}
Patches
We have patched the issue in GitHub commit 37e64539cd29fcfb814c4451152a60f5d107b0f0. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| tensorflow | < 2.7.2 |
2.7.2 |
| tensorflow | >= 2.8.0, < 2.8.1 |
2.8.1 |
| tensorflow | >= 2.9.0, < 2.9.1 |
2.9.1 |
| tensorflow | < 2.7.2>= 2.8.0, < 2.8.1>= 2.9.0, < 2.9.1 |
2.7.22.8.12.9.1 |
| tensorflow-cpu | < 2.7.2 |
2.7.2 |
| tensorflow-cpu | >= 2.8.0, < 2.8.1 |
2.8.1 |
| tensorflow-cpu | >= 2.9.0, < 2.9.1 |
2.9.1 |
| tensorflow-cpu | < 2.7.2>= 2.8.0, < 2.8.1>= 2.9.0, < 2.9.1 |
2.7.22.8.12.9.1 |
| tensorflow-gpu | < 2.7.2 |
2.7.2 |
| tensorflow-gpu | >= 2.8.0, < 2.8.1 |
2.8.1 |
| tensorflow-gpu | >= 2.9.0, < 2.9.1 |
2.9.1 |
| tensorflow-gpu | < 2.7.2>= 2.8.0, < 2.8.1>= 2.9.0, < 2.9.1 |
2.7.22.8.12.9.1 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
tensorflow PyPI → 2.7.2
- pip
pip install --upgrade "tensorflow>=2.7.2"- poetry
poetry add "tensorflow>=2.7.2"- uv
uv add "tensorflow>=2.7.2"
tensorflow-cpu PyPI → 2.7.2
- pip
pip install --upgrade "tensorflow-cpu>=2.7.2"- poetry
poetry add "tensorflow-cpu>=2.7.2"- uv
uv add "tensorflow-cpu>=2.7.2"
tensorflow-gpu PyPI → 2.7.2
- pip
pip install --upgrade "tensorflow-gpu>=2.7.2"- poetry
poetry add "tensorflow-gpu>=2.7.2"- uv
uv add "tensorflow-gpu>=2.7.2"
Weakness
CWE-190: Integer Overflow or Wraparound
The product performs a calculation that can produce an integer overflow or wraparound when the logic assumes that the resulting value will always be larger than the original value. This occurs when an integer value is incremented to a value that is too large to store in the associated representation. When this occurs, the value may become a very small or negative number.
How to prevent it
- Requirements: Ensure that all protocols are strictly defined, such that all out-of-bounds behavior can be identified simply, and require strict conformance to the protocol.
- Requirements: Use a language that does not allow this weakness to occur or provides constructs that make this weakness easier to avoid. If possible, choose a language or compiler that performs automatic bounds checking.
- Architecture and Design: Use a vetted library or framework that does not allow this weakness to occur or provides constructs that make this weakness easier to avoid [REF-1482]. Use libraries or frameworks that make it easier to handle numbers without unexpected consequences. Examples include safe integer handling packages such as SafeInt (C++) or IntegerLib (C or C++). [REF-106]
- Implementation: Perform input validation on any numeric input by ensuring that it is within the expected range. Enforce that the input meets both the minimum and maximum requirements for the expected range. Use unsigned integers where possible. This makes it easier to perform validation for integer overflows. When signed integers are required, ensure that the range check includes minimum values as well as maximum values.
- Implementation: Understand the programming language's underlying representation and how it interacts with numeric calculation (CWE-681). Pay close attention to byte size discrepancies, precision, signed/unsigned distinctions, truncation, conversion and casting between types, "not-a-number" calculations, and how the language handles numbers that are too large or too small for its underlying representation. [REF-7] Also be careful to account for 32-bit, 64-bit, and other potential differences that may affect the numeric representation.
- Architecture and Design: For any security checks that are performed on the client side, ensure that these checks are duplicated on the server side, in order to avoid CWE-602. Attackers can bypass the client-side checks by modifying values after the checks have been performed, or by changing the client to remove the client-side checks entirely. Then, these modified values would be submitted to the server.
- Implementation: Examine compiler warnings closely and eliminate problems with potential security implications, such as signed / unsigned mismatch in memory operations, or use of uninitialized variables. Even if the weakness is rarely exploitable, a single failure may lead to the compromise of the entire system.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gjh7-xx4r-x345 TensorFlow has segfault in array_ops.upper_bound | High | Also affects tensorflow |
| GHSA-fxgc-95xx-grvq TensorFlow Denial of Service vulnerability | Medium | Also affects tensorflow |
| GHSA-93vr-9q9m-pj8p TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch | High | Also affects tensorflow |
| GHSA-qjqc-vqcf-5qvj TensorFlow vulnerable to seg fault in `tf.raw_ops.Print` | High | Also affects tensorflow |
| GHSA-7jvm-xxmr-v5cw TensorFlow vulnerable to integer overflow in EditDistance | High | Also affects tensorflow |
| GHSA-64jg-wjww-7c5w TensorFlow has Null Pointer Error in TensorArrayConcatV2 | High | Also affects tensorflow |
| GHSA-6hg6-5c2q-7rcr TensorFlow has Heap-buffer-overflow in AvgPoolGrad | High | Also affects tensorflow |
| GHSA-558h-mq8x-7q9g TensorFlow has Null Pointer Error in SparseSparseMaximum | High | Also affects tensorflow |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor