GHSA-qvf5-hvjx-wm27 BIT-tomcat-2024-52317 CVE-2024-52317
Apache Tomcat Request and/or response mix-up
- Severity
- 6.5 / 10
- Medium · CVSS 3.1
- Exploit chance (EPSS)
- 2.10%
- Chance of exploitation in the next 30 days. Higher than 81.68% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-326 Inadequate Encryption Strength
- Fix
- Available
- 2 packages have a fixed version
Description
Incorrect object re-cycling and re-use vulnerability in Apache Tomcat. Incorrect recycling of the request and response used by HTTP/2 requests could lead to request and/or response mix-up between users.
This issue affects Apache Tomcat: from 11.0.0-M23 through 11.0.0-M26, from 10.1.27 through 10.1.30, from 9.0.92 through 9.0.95.
Users are recommended to upgrade to version 11.0.0, 10.1.31 or 9.0.96, which fixes the issue.
Affected versions
Maven
| Package | Vulnerable | Fixed in |
|---|---|---|
| org.apache.tomcat.embed:tomcat-embed-core | >= 9.0.92, < 9.0.96 |
9.0.96 |
| org.apache.tomcat.embed:tomcat-embed-core | >= 10.1.27, < 10.1.31 |
10.1.31 |
| org.apache.tomcat.embed:tomcat-embed-core | >= 11.0.0-M23, < 11.0.0 |
11.0.0 |
| org.apache.tomcat:tomcat-coyote | >= 9.0.92, < 9.0.96 |
9.0.96 |
| org.apache.tomcat:tomcat-coyote | >= 10.1.27, < 10.1.31 |
10.1.31 |
| org.apache.tomcat:tomcat-coyote | >= 11.0.0-M23, < 11.0.0 |
11.0.0 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
org.apache.tomcat.embed:tomcat-embed-core Maven → 9.0.96
- maven
<dependency><groupId>org.apache.tomcat.embed</groupId><artifactId>tomcat-embed-core</artifactId><version>9.0.96</version></dependency>- gradle
implementation("org.apache.tomcat.embed:tomcat-embed-core:9.0.96")
org.apache.tomcat:tomcat-coyote Maven → 9.0.96
- maven
<dependency><groupId>org.apache.tomcat</groupId><artifactId>tomcat-coyote</artifactId><version>9.0.96</version></dependency>- gradle
implementation("org.apache.tomcat:tomcat-coyote:9.0.96")
Severity breakdown
CVSS 3.1 6.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Weakness
CWE-326: Inadequate Encryption Strength
The product stores or transmits sensitive data using an encryption scheme that is theoretically sound, but is not strong enough for the level of protection required.
How to prevent it
- Architecture and Design: Use an encryption scheme that is currently considered to be strong by experts in the field.
References
Advisories
Packages
Other links
- github.com/apache/tomcat/commit/146f94f87ea398fb592c7a20a5ccbef95e9dd72b
- github.com/apache/tomcat/commit/47307ee27abcdea2ee40e33897aca760083de46a
- github.com/apache/tomcat/commit/9e840ccacb40881c03a03b1e0746bfba7369b3bd
- lists.apache.org/thread/ty376mrxy1mmxtw3ogo53nc9l3co3dfs
- security.netapp.com/advisory/ntap-20250124-0004
- openwall.com/lists/oss-security/2024/11/18/3
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-83qj-6fr2-vhqg Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT | Critical Known exploited | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-qppj-fm5r-hxr3 HTTP/2 Stream Cancellation Attack | Medium Known exploited | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-xjgh-84hx-56c5 Unrestricted Upload of File with Dangerous Type Apache Tomcat | High Known exploited | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| CVE-2020-1938 Improper Privilege Management in Tomcat | Critical Known exploited | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-pjfr-qf3p-3q25 When running Apache Tomcat on Windows with HTTP PUTs enabled it was possible to upload a JSP file to the server | High Known exploited | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-h3x4-894j-xpx5 Apache Tomcat's FORM authentication process has an Incorrect Authorization vulnerability | Critical | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-9xv2-5v5q-p794 Apache Tomcat's DIGEST authenticator has an Authentication Bypass by Capture-replay vulnerability | Critical | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-f525-44xv-f2qj Apache Tomcat - HTTP/2 no-authority bypass of strict SNI validation | Critical | Also affects org.apache.tomcat.embed:tomcat-embed-core |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor