GHSA-qqgj-22gr-73vx CVE-2016-4041 PYSEC-2017-55
Plone vulnerable to privilege escalation in WebDAV
- Severity
- 0.0 / 10
- High · CVSS 4.0
- Exploit chance (EPSS)
- 1.49%
- Chance of exploitation in the next 30 days. Higher than 74.18% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- —
- Not classified
- Fix
4.3.10- Upgrade plone to this version or later
Description
Plone 4.0 through 5.1a1 does not have security declarations for Dexterity content-related WebDAV requests, which allows remote attackers to gain webdav access via unspecified vectors.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| plone | >= 3.3, < 4.3.10 |
4.3.10 |
| plone | >= 5.0, < 5.0.5 |
5.0.5 |
| plone | >= 5.1a1, < 5.1a2 |
5.1a2 |
| plone | >= 4.0, < 5.1a2 |
5.1a2 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
plone PyPI → 4.3.10
- pip
pip install --upgrade "plone>=4.3.10"- poetry
poetry add "plone>=4.3.10"- uv
uv add "plone>=4.3.10"
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
- Attack vector
- Network
- Attack complexity
- Low
- Attack requirements
- None
- Privileges required
- None
- User interaction
- None
- Confidentiality (vulnerable system)
- Low
- Integrity (vulnerable system)
- Low
- Availability (vulnerable system)
- Low
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.0 7.3
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-xg5p-8wg5-rhxm Phone information disclosure vulnerability | High | Also affects plone |
| GHSA-5xfx-55x4-j223 Cross-Frame Scripting vulnerability has been found on Plone CMS | High | Also affects plone |
| GHSA-47p5-p3jw-w78w Server-Side Request Forgery in Plone CMS | High | Also affects plone |
| GHSA-cvwc-g7fw-7xrj Plone XSS Vulnerability | Medium | Also affects plone |
| GHSA-pwgm-jvqv-6v8p Plone anonymous access to sub-objects in CMFEditions where KwAsAttributes classes were publishable | High | Also affects plone |
| GHSA-46f9-f8jm-mw2x Plone Cross-site Scripting vulnerability in the LiveSearch module | Medium | Also affects plone |
| GHSA-hjp5-hv33-q58g Plone credentials stored in session cookie | Medium | Also affects plone |
| GHSA-593c-j348-f3gv Plone Improper Session Management | High | Also affects plone |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor